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INTRODUCTION
Welcome to the New Horizons training team.

Our goal is to provide you with the best computer training available and we
know exactly what that takes. Our corporate heritage is based in training. In fact,
we use our Student Manuals every day, in classes just like yours, so you can be
confident that the material has been tested and proven to be effective.

If you have any suggestions on how we can improve our products or services,
please contact us.

ABOUT THIS COURSE
creating objects and animating in Macromedia’s Flash MX. You will explore the
basics of Flash, including tools and features, and will create different types of
animations. Finally, you will publish material for the Web.

Course Prerequisites
In order to take this course, you need to be familiar with your computer’s operat-
ing system and basic operation.

Course Objectives
When you’re done working your way through this book, you’ll be able to:

• View a Flash movie and modify the appearance of the Stage.

• Draw, paint, and create custom colors, gradients, and line styles.

• Manipulate objects, describe shape interaction, and import artwork.

• Add text and manipulate its behavior and appearance.

• Build layers and use them to create various effects.

• Create frame-by-frame, shape-tweened, and motion-tweened animation.

• Publish a Flash movie.

ABOUT THIS
COURSE

About This Course vii

Flash MX - Level 1 is a hands-on course that will introduce you to the basics of
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COURSE SETUP INFORMATION

Hardware and Software Requirements
To run this course, you will need:

• An Intel Pentium 200 MHz or equivalent processor

• Windows 98 SE, Me, NT4, 2000, or XP.

• 64 MB of random-access memory (128 MB recommended) plus a minimum
of 85 MB of available disk space (64 recommended).

• 1024 x 768, 16-bit (thousands of colors) color display or better

• Either Microsoft Internet Explorer 5.0 and/or Netscape Navigator 4.0 (or
later version).

• Macromedia Flash MX.

• A CD-ROM drive.

Class Requirements
In order for the class to run properly, perform the procedures described below.

1. Install Macromedia Flash MX. A trial version can be downloaded from
http://www.macromedia.com/software/downloads/. If you already have a
full version of Flash MX installed on your computer, this course will run
best if you uninstall and reinstall Flash to reset the application to its default
settings. Warning: Uninstalling and reinstalling Flash will require you to
re-enter the serial number of the program. If you do not have the serial num-
ber and installation CD available, do not uninstall.

2. Install the course data files that come with this book. Open the contents
of the CD-ROM through My Computer, and open the 078_164 folder. Inside
this folder, you will find three separate folders. Copy the Flash MX Level 1
Data folder to your C:\ drive. This folder contains all the data material you
will need for the course.

3. Make sure that you have a Web browser properly installed on your
computer. It is suggested that you have both Netscape Navigator and
Microsoft Internet Explorer installed, since they are the two most popular
browsers.

4. In the 078_164 folder on the course CD, the Lesson folders in the Additional
Data folder contain all the course images and data, completed up to the les-
son indicated by the folder name. This allows you to begin at any lesson in
this manual using the correct data that includes all files that would have
been created from previous lessons. It also allows you to begin a new lesson
with fresh, correct data, if so desired.

For example, if you would like to begin this manual at Lesson 4, you should
open the Lesson 4 folder in the Additional Data folder in the 078_164 folder
on the course CD, and copy the Flash MX Level 1 Data folder from the
Lesson 4 folder to your computer’s hard disk. All the files you’ll need to
complete the rest of the course are contained in the new folder.

ABOUT THIS
COURSE
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However, the files in the new Flash MX Level 1 Data folder are in read-only
format. Therefore, you should now open the data folder you just copied to
your computer’s hard disk. Choose Edit→Select All to select all the icons
in the folder, then choose File→Properties, uncheck the Read Only
checkbox, and click OK.

HOW TO USE THIS BOOK
You can use this book as a learning guide, a review tool, and a reference.

As a Learning Guide
Each lesson covers one broad topic or set of related topics. Lessons are arranged
in order of increasing proficiency with Flash MX; skills you acquire in one lesson
are used and developed in subsequent lessons. For this reason, you should work
through the lessons in sequence.

We organized each lesson into explanatory topics and step-by-step activities. Top-
ics provide the theory you need to master Flash MX, activities allow you to apply
this theory to practical hands-on examples.

You get to try out each new skill on a specially prepared sample file. This saves
you typing time and allows you to concentrate on the technique at hand. Through
the use of sample files, hands-on activities, illustrations that give you feedback at
crucial steps, and supporting background information, this book provides you
with the foundation and structure to learn Flash MX quickly and easily.

As a Review Tool
Any method of instruction is only as effective as the time and effort you are will-
ing to invest in it. For this reason, we encourage you to spend some time
reviewing the book’s more challenging topics and activities.

As a Reference
You can use the Concepts sections in this book as a first source for definitions of
terms, background information on given topics, and summaries of procedures.

ABOUT THIS
COURSE
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The Flash Environment

Overview
In this lesson, you will be introduced to the concepts and technology behind
Flash. You will also explore the Flash environment, including the workspace
options, features, tools, and panels available in Flash.

Objectives
In order to become familiar with the Flash environment, you will:

1A Identify the advantages of Flash as a Web development tool.

Flash is fast becoming a Web standard, thanks to the accessibility of the
Flash Player, as well as its speed and ease of use.

1B Identify the main components of the Flash work environment and
describe their purpose.

You will determine the type of set up for your workspace, examine the
different tools and features, and explore the use of panels in the Flash
work environment.

Data Files
jammin_banner.html
jammin_banner.fla

Lesson Time
45 minutes

LESSON

1
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Topic 1A
What is Flash?
When they want to add interactive animation to a Web site, many Web designers
and developers turn to Flash. Ranging from state-of-the-art user interfaces to
logos to animated movies, you’ll find Flash movies on corporate, entertainment,
and personal Web sites throughout the Internet.

Flash has become the Web design tool of choice for several reasons. First, Flash
provides Web developers and designers with greater control over the display of
their work. When designing Web pages without Flash, the end result is at the
mercy of the browser on which the user views the site. Using Flash allows you,
as the designer, to determine exactly how the site will function and appear,
regardless of the browser used, simply because it will be viewed using the Flash
Player. Add to this the Flash Player’s easy accessibility (it is included in major
Web browsers, system software, and often ships standard on new computers, as
well as being easily downloaded from the Macromedia site) and you can see why
Flash has become a Web standard.

Flash packs a lot of functionality into one easy-to-use program. Not only can you
create animated movies from scratch with Flash, but you can also import graphic
content created with other programs and use Flash to animate it.

However, download times may still be affected by the type of connection the
viewer has, so you do need to consider that in creating an animation. You’ll take
a greater look at vector and raster graphic formats in a later section.

TASK 1A-1:
Viewing a Flash Movie

1. Launch your Web browser (either Internet Explorer or Netscape
Navigator).

2. Choose File→Open. The Open dialog box appears.

3. Navigate to the Flash MX Level 1 Data folder and open the
banner_example.html file. The Flash animation plays as it would when
viewed on the Web.

4. Close the browser window.

2 FlashMX - Level 1 (Windows)

DO
 N

O
T 

DU
PL

IC
AT

E

In
st

ru
ct

or
 E

di
tio

n



5. Launch the Flash application.

6. Open the banner_example.fla file in the Flash MX Level 1 Data folder.
When the file opens, Flash displays the first frame of the movie in the Flash
work environment.

7. Choose Control→Play. The animation plays. This is the type of animated
effect that you can create with Flash.

8. Close the file and do not save any changes.

Topic 1B
The Flash Work Environment
Whether you’re creating or editing Flash files, you’ll work with these key tools:
the Stage, the work area, and the Timeline. You’ll also use the tools in the
Toolbox and the panels to create and manipulate objects.

Flash Features and Tools
The Flash work environment provides a wide range of features and tools, as
shown in Figure 1-1.

Figure 1-1: The Flash environment provides a wide variety of tools and features.

The Stage. The Stage is the large, rectangular area in the workspace where you’ll
create and place all the content for your movie. When you play a movie, it
appears here. You can draw or import new objects for your movie on the Stage.

The default Stage color is white. You can modify the background color or even
import a bitmap graphic to serve as a background. You can also add tools like
rulers or grids to the Stage to help with layout and positioning.

The work area. The gray area surrounding the Stage is known as the work area.
You can use this area when working with animation objects that will move on
and off the Stage.

If this is the first time you’ve
opened Flash on your
computer, you may see a
dialog box asking whether
you’d like to register the
software. Click Register Later
to close this dialog box.

You may want to direct
students to close the
panels which open
automatically with Flash if
they need more screen
space.
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The Toolbox. The Toolbox contains all the tools you’ll need to create and modify
Flash artwork. There are tools for drawing, painting, selecting, and editing. There
are four sections in the Toolbox: Tools, which includes selecting, drawing, and
painting tools; View, which offers tools for customizing your view of the Stage;
Colors, which presents tools for changing outline and fill colors; and Options,
which displays modifiers for the currently selected tool.

The Timeline. You’ll use the Timeline to organize your movie’s content with lay-
ers and frames. With layers, you can create a stacking order which controls the
way objects appear and interact. Frames determine what content appears at a par-
ticular point in your movie. When you select a frame in a movie, all of the
content on all of the layers included in that specific frame will display on the
Stage. The Timeline is resizable, allowing you to display as many layers as you
wish.

Panels. Flash’s panels provide options for working with objects, colors, text,
instances, frames, and entire movies. You can use panels to view, organize, and
change elements in a movie. Each panel focuses on a specific area. For example,
you can use the Color Mixer panel to create and edit colors. The default panel
layout includes the Color Mixer, Color Swatches, Components, Answers, Actions,
and Properties panels.

Panels can float on your screen, or can be docked below or to the right of the
work area and Timeline. You can use either the preset Developer or Designer
panel sets or you can create and save custom panel layouts that are suited to your
needs. Panels can be opened, closed, and repositioned as desired.

The Property Inspector. The Property Inspector provides information about the
document you are working on, or the specific object within a movie. When no
object is selected, it displays the attributes of the movie you are working on. If an
object is selected, it displays the most commonly used attributes for that item,
whether it is a symbol, shape, bitmap, video, group, frame, or text. This simpli-
fies the design and development process by allowing you to make changes to the
document or object without having to access menus or panels.

Developer vs. Designer
Flash has several preset workspaces that allow you to access the tools and fea-
tures that will be most useful to you in working on movies. You can choose
between panels which emphasize design or development work within Flash. The
Designer panel sets focus on media elements in Flash, such as color mixing and
transforming objects. The Developer panels provide access to advanced scripting
and debugging tools. However, within all the developer and designer sets, panels
can still be added, closed, or moved as you need them.

layer:
An organizational element
that enables you to stack

images on top of one
another.

frame:
A movie segment composed

of an individual image.
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TASK 1B-1:
Exploring the Flash Work Environment

1. In this task, you will set up your work environment and determine the initial
settings for a banner ad for a company called Jammin’ Juice, which you will
create throughout the course. Launch the Flash application.

2. The Info panel provides information on the location and size of objects on
the screen and will be helpful as you create your movie. You will show the
Info panel. Choose Window→Info. The Info panel appears.

3. You will dock the Info panel so that it is in the panel area to the right of the
work area. Position the cursor over the Info panel handle, so that a move
cursor appears.

4. Drag the Info panel over the Panel docking area to the right of the
Stage, and release the mouse button when a grey line appears on either
side of the panel area. The Info panel is now docked with the other panels.

5. Next you will close the Components panel because you will not be using it
in this course. Choose Close Panel from the Components panel drop-
down list in the upper right corner of the Components panel. The
Components panel no longer appears below the work area.

6. Rather than continuing to open or close individual panels that will be used
in the movie, you can choose a panel set. You will select a designer panel
set to work with as you design an animation in this course. Choose
Window→Panel Sets→Designer (1024x768). The Property Inspector
remains below the work area and the Info, Align, Transform, Color Mixer,
Color Swatches, Components, and Answers panels appear in the panel area.

7. Next, you will set the size of the Stage for your movie. Because you have
no other objects selected, the Property Inspector allows you to make selec-
tions for the movie’s appearance. Click on the Size button in the Property
Inspector. The Document Properties dialog box appears and the width
dimension is selected.

8. You will leave the width of the document as it is, but change the height so
that it is shorter and more appropriate for a banner ad. Type 130 in the
Height dimension field.

9. You will leave the rest of the settings as they are. Click OK.

If you are using a higher
resolution, you can choose a
designer set for either 1280
x 1024 or 1600 x 1200.
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10. Finally, you will add grid lines to use as guides as you are developing
objects on the Stage. Choose View→Grid→Show Grid. Light grey grid
lines appear on the Stage.

11. You are finished setting up your document. Save the document as
jammin_banner.fla in the Flash MX Level 1 Data folder.

Summary
In this lesson, you viewed a Flash movie. You were introduced to Flash, and
its benefits for Web development and animation. You also chose a panel set
to work with, added and closed panels, and set initial movie characteristics
using the Property Inspector.

Lesson Review
1A What advantages does Flash offer as a Web development tool?

Answers will vary, but may include: greater control over display, accessibil-
ity of the Flash Player, range of functionality in Flash program, and small
file size.

1B What are the main components of the Flash work environment?
Describe their functions.

The Stage, which is where movie elements are created and placed; the work
area, where animations from a movie may move in and out of the Stage; the
Toolbox, which contains tools for creating and modifying Flash artwork; the
Timeline, where movie content can be organized with layers and frames;
Panels, where you can view, organize and change elements in a movie; and
the Property Inspector, where you can change attributes of the whole movie,
or selected objects on the Stage.

6 FlashMX - Level 1 (Windows)
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Drawing and Painting

Overview
Flash offers a wide variety of drawing and painting tools, allowing you to
create interesting objects for your movies. In this lesson you will explore
Flash’s basic drawing and painting tools, modify outline and fill properties,
and create custom color swatches, gradients and line styles.

Objectives
In order to draw and paint in Flash, you will:

2A Explain the difference between vector and raster graphics.

Flash’s small file sizes are based on using vector graphics.

2B Create objects using Flash drawing and painting tools.

Flash provides several useful tools for creating graphic objects, including
the pencil, pen, line, brush, oval, rectangle, and eraser tools.

2C Create a custom color swatch, gradient, and line style.

While Flash provides a wide variety of preset colors, gradients, and line
styles to choose from, often you will need to expand on those for movies
you are working on.

Data Files
circles.fla
fruit.fla

Lesson Time
1 hour

LESSON

2
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Topic 2A
Vector vs. Raster Graphics
Before you start to work with Flash, you should become familiar with two graph-
ics formats: vector and raster. Flash allows you to create and animate vector
graphics. You can also import and manipulate raster graphics with Flash.

Vector Graphics
Vector graphics are composed of lines and curves defined by mathematical
equations. There are several advantages to using vector graphics on your Web
site. For example, vector graphics have a smaller file size than raster graphics,
which will save download time for visitors to your site. They are also resolution
independent, so they can be resized without distortion. This is due to the fact that
when you edit vector graphics, you are actually modifying the properties of the
lines and curves which compose the image. Additionally, the vector format will
print at whatever resolution a printer allows, because of the mathematical instruc-
tions that are contained within them. However, editing complex vector graphic
objects can be difficult because they are composed of many smaller objects.

Raster Graphics
Raster graphics, also known as bitmaps, are composed of a grid (or raster) of
small squares called pixels. Each pixel in a raster graphic can be a different color
or shade of gray. While this allows for detailed and complex images, it also
causes raster images to have large file sizes because they must store information
about the color of each individual pixel. When you resize a raster graphic, it can
become distorted because of the way the pixels are redistributed on the grid.
Because the data which describes a raster image is fixed to the size of the grid,
these graphics are resolution dependent. For this reason, a raster graphic will
appear distorted when it is viewed on a computer set at a lower resolution than
the one at which it was created. You can import raster graphics into Flash and
work with them, but you’ll have limited control over their appearance. One ben-
efit of importing a raster graphic into Flash is that Flash will compress it to a
smaller file size.

For example, imagine you have an image of a line that is 50 pixels in length dis-
played on your screen. If the image were a raster graphic, it would be defined by
50 separate pixels, since each pixel’s color could be different. If, on the other
hand, you were working with a vector graphic, the image would be defined by an
internal mathematical equation that recognizes a starting and ending point for the
line. This results in a smaller file size because your computer will not try to rec-
ognize every pixel that is used within the graphic image.

vector graphic:
A graphic image defined by

mathematical equations.

raster graphic:
A graphic image defined by

grids composed of pixels.

bitmap:
A graphic image defined by

grids composed of pixels;
raster graphic.

pixels:
Picture elements. Small

squares which are arranged
on a grid to create raster

graphics.
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TASK 2A-1:
Comparing Vector and Raster Images

1. Open the circles.fla file in the Flash MX Level 1 Data folder. The circle
on the left was created with a raster image graphics program. The circle on
the right is a vector image created in Flash. Both images look similar.

2. You will take a closer look at the circles. Choose 400% from the Zoom
drop-down list, located in the upper right corner of the Stage. You can
see the individual pixels which compose the shape on the left, while the one
on the right remains a smooth curve.

3. Choose 100% from the Zoom drop-down list to return the magnification
to actual size.

4. Close the file and save any changes.

Topic 2B
Basic Drawing and Painting Tools
The Toolbox, shown in Figure 2-1, is full of drawing tools that you can use to
create the objects for your animations. It’s a good idea to become familiar with
these tools for creating and modifying simple shapes. Since Flash is a vector-
based program, these simple shapes become the building blocks of more complex
shapes. Many of these tools also have several modes which allow you to modify
their function slightly, depending on the task at hand.

Lesson 2: Drawing and Painting 9
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Figure 2-1: The Flash Toolbox provides a variety of drawing and painting tools.

Perhaps the most basic drawing tool Flash offers is the Pencil tool. With this tool,
you can draw free-form shapes, lines, and curves. The Pencil tool also has three
modifier modes, straighten, smooth, and ink, from which you can select to change
the look of your lines.

TASK 2B-1:
Working with the Pencil Tool

1. You will begin by creating a new document. Choose File→New.

2. Select the Pencil tool . The Pencil Mode button appears in the Options
section of the Toolbox.

3. Click on the Pencil Mode button and verify that Straighten is
selected. This modifier will convert curved line segments into straight
segments. It will also convert rough circles, squares, and triangles into neat,
geometric shapes.

4. Using the Pencil tool, drag the cursor across the Stage to draw a heart
shape. Your curved lines are straightened. This feature can be useful when
you’re drawing shapes with perpendicular lines.

10 FlashMX - Level 1 (Windows)
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5. Draw a circle on the Stage. If Flash recognizes the shape you have drawn,
your drawing will be straightened into a perfect circle.

6. To clear the Stage, choose Edit→Select All, then press the [Backspace]
key.

7. Next, you will use the pencil in Smooth mode. When you draw in Smooth
mode, jagged line segments are converted to smooth, curved lines. In the
Pencil Mode drop-down list, choose Smooth .

8. Draw a heart on the Stage. Flash converts rough areas to smooth curves.

9. Draw a circle on the Stage. Flash smooths the lines, but doesn’t convert the
shape to a perfect circle.

10. Choose Edit→Select All, then press the [Backspace] key to clear the
Stage.

11. The final mode for drawing with the Pencil tool is Ink. In Ink mode, Flash
won’t make any modifications to the shapes you draw. In the Pencil Mode
drop-down list, choose Ink .

12. Draw heart and circle shapes on the Stage.

13. You can draw perfectly straight lines in any pencil drawing mode by holding
down the [Shift] key as you draw. Hold down the [Shift] key as you draw
a straight line on the Stage.

14. Choose Edit→Select All, then press the [Backspace] key to clear the
Stage.

The Pen Tool
The Pen tool is useful for drawing precise paths with straight lines or smooth
curves in vector format. To create the lines and curves, you click to set two or
more anchor points for the line, adjusting the direction of curves you have drawn
by moving the tangent handles. To draw straight lines with the Pen tool, click to
place the ending, or anchor, point of the line. As with other tools, holding down
the [Shift] key constrains the lines you create to 45° angles.

To draw a curved line, place the first anchor point and then drag in the direction
you want the curve to go. Once you have reached the end of where you want the
curve to go, release the mouse button. To readjust the curve once it is placed, you
can change the tangent handles, which determine the slope and the height of the
curve. For each anchor point on a curve, there are two tangent handles which
control the curve, which will move simultaneously when you adjust the curve.

anchor points:
Locations on a vector line or
curve which determine the
length and direction of the
line.

tangent handle:
The part of a vector curve
which can be adjusted to
determine the slope and the
depth of the curve.
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TASK 2B-2:
Drawing with the Pen Tool

1. You will draw a letter “j” for the Jammin’ Juice banner ad, to accompany
other text that you will add later. Open the jammin_banner.fla file in the
Flash MX Level 1 Data folder. A Stage appears that is 550x130 pixels and
has grey grid lines.

2. You will zoom in on the left hand side of the Stage so that you can draw
with the Pen tool easier. Type 150 in the Zoom field above the Stage and
scroll so that the left side of the Stage is showing.

3. Select the Pen tool in the Toolbox.

4. First you will draw straight lines with the Pen tool. Click on the first hori-
zontal grid line, midway between the second and third vertical grid
lines.

5. Click on the intersection of the first horizontal and fourth vertical
gridline. A line one and a half grid squares long appears.

6. Click on the intersection of the fourth horizontal and fourth vertical
gridline. A vertical line three grid squares long appears.

7. Position the cursor on the sixth horizontal grid line, approximately half-
way between the second and third vertical grid line, drag approximately
one grid square to the left, and release the mouse button.

To access more room to
work on the Stage, you may

want to collapse the Timeline
and Property Inspector

windows.
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8. Position the cursor on the first vertical grid line, approximately midway
between the third and fourth horizontal grid line, drag up approxi-
mately 11⁄2 grid squares, and release the mouse button.

9. Draw a straight line segment approximately 1⁄2 grid square long, and
parallel to the horizontal grid lines. Instead of a straight line, Flash draws
a curved line, using the tangent line from the last curve to determine the
direction of the new line.

10. Choose Edit→Undo. The last curved line is gone.

11. To create a horizontal line, without it curving, you will click the Arrow tool
to deselect the Pen tool. Click the Arrow tool. The lines you drew are no
longer selected.

12. To finish the “j” you will continue using the Pen tool. Click the Pen tool.

13. Click anywhere on the line segments you have drawn. The anchor points
appear and the line segments are once again selected.

14. Click on the last anchor point you drew.

15. Click to create a short horizontal line segment, parallel to the grid, and
approximately half a grid square in length.

Lesson 2: Drawing and Painting 13
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16. Next you will create the internal curve of the “j.” Position the cursor mid-
way between the second and third vertical grid lines, on the fourth
horizontal grid line, and drag the tangent handle approximately one half
grid square to the right to create the curve.

17. Click to create a symmetrical curve on the other side of the third verti-
cal grid line. Flash automatically creates a curve with the same dimensions
as the one you just drew.

18. Click on the intersection of the third vertical and second horizontal grid
lines.

19. Click directly below the first anchor point, but on the second horizontal
line.

14 FlashMX - Level 1 (Windows)
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20. Click on the original anchor point to close the shape. Flash automatically
fills the shape with the fill color in the Toolbox.

21. Choose File→Save.

Shape Tools and their Properties
You can use the Line, Oval, and Rectangle tools to draw perfect lines, ovals,
circles, rectangles, and squares. Each of these tools allows you to choose outline
properties for the outlines of the shapes you create. You can change the type of
outline (dashed, dotted, hairline, etc.), the color of the line, and the line width.

You can also modify the colors which fill the objects when using both of these
tools. Additionally, the Rectangle tool includes a modifier that you can use to
draw squares and rectangles with rounded corners. Finally, holding down the
[Shift] key with the tools constrains the tool geometrically: the Line tool creates
lines that are in multiples of 45 degrees, the Oval tool creates only circles, and
the Rectangle tool creates only squares.

Stroke and Fill Properties
When you create a shape using any of the drawing or painting tools, you’ll work
with both interior fills and exterior strokes. To change the color of an object’s
stroke or fill, you’ll use the Colors section of the Toolbox. When you click on the
color button for either stroke or fill, Flash will display a drop-down color palette
with a variety of options. To change the stroke properties of a line or shape out-
line, you will use the Property Inspector.

Web-safe Colors
All of the colors in the Flash default palette are Web-safe colors. Whether you
use a Windows PC or a Macintosh, provided the machine has a 256-color video
card, these colors will appear correctly. It’s a good idea to use Web-safe colors in
your Flash movies.

Lesson 2: Drawing and Painting 15
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TASK 2B-3:
Properties of Shapes

1. Currently the “j” that you drew in the previous activity has a default fill and
outline. You will change both the stroke and the fill of the letter. With the
Arrow tool, click inside the letter to select it. Only the fill of the letter, not
the stroke, is selected.

2. Click on the Fill color button in the Toolbox and choose a dark purple
color from the drop-down list.

3. Double-click anywhere on the edge of the letter to select its outline.

4. To change the stroke of an object, you can change the color in the Color
section of the Toolbox, or you can make other changes to the line using the
Property Inspector. Choose 4 from the Stroke Height drop-down list in
the Property Inspector. The line around the letter is now 4 pixels wide.

5. Choose the Dashed style from the Stroke Style drop-down list in the
Property Inspector.

6. Click anywhere on the Stage to deselect the letter stroke. A dashed line
appears around the letter.

7. Select the line again and change the color to light pink.

8. Finally, you will use the oval tool to create the dot for the “j.” Click on the
Oval tool in the Toolbox. The cursor changes to a crosshair.

9. Hold down the [Shift] key and drag to create a circle approximately half
a grid square wide and long above the “j.” You have drawn a circle with
the same fill and stroke you specified earlier.

10. Choose File→Close and save the changes you made to the file.

16 FlashMX - Level 1 (Windows)
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The Brush Tool
Another useful drawing tool, the Brush tool can be used to draw freehand shapes,
similar to the pencil tool, or to add a solid fill to an existing shape. Like the paint
brush for which it is named, this tool offers a variety of brush sizes and shapes,
enabling you to create a range of painting effects. The Brush tool also provides
five modifiers, described in Figure 2-2, which govern the tool’s behavior.

Modifier Description
Paint Normal Paints any part of the object covered by the stroke

of the brush.
Paint Fills Paints any fills covered by the stroke of the brush.
Paint Behind Paints the area around the object, so that the

object appears in front of the brush strokes.
Paint Selection Paints whatever has been selected by the arrow

tool.
Paint Inside Paints gaps or spaces between strokes in the

object.

Figure 2-2: Modifiers for the Brush tool.

TASK 2B-4:
Working with the Brush Tool

1. Open fruit.fla in the Flash MX Level 1 Data folder.

2. You’ll experiment with the Brush tool by modifying the objects on this page.
Select the Brush tool . The brush modifiers appear in the Options sec-
tion of the Toolbox.

3. Select the third size from the top from the Brush size drop-down list.

4. Select the circular shape from the Brush Shape drop-down list, if
necessary.

5. First, you’ll use the Paint Normal mode to paint over existing colors with a
new color. Select a light green fill color in the Colors section of the
Toolbox.

6. Drag across the grapes to paint several green strokes. The green fill com-
pletely covers the areas where you painted.

7. To remove the green brush stokes, choose Edit→Undo as many times as
is necessary.

Lesson 2: Drawing and Painting 17
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8. Next you will use the Paint Fills mode of the Brush tool. Choose Paint Fills
from the Brush Mode drop-down list .

9. Paint several strokes across the grapes. Only the fill color of the grapes is
covered, while the stroke color remains intact.

10. Choose Edit→Undo to return the grapes to their original state.

11. Next you will use the Paint Behind mode of the Brush tool. Choose Paint
Behind from the Brush Mode drop-down list .

12. Drag to paint several strokes across the grapes and out onto the Stage.
This time, only the strokes outside the grapes will show, giving the effect
that the strokes were painted behind the grapes.

13. Choose Edit→Undo to remove the brush strokes.

14. Next you will use the Paint Selection mode of the Brush tool. Choose Paint
Selection from the Brush Mode drop-down list .

15. Click on the Arrow tool, then select the bottom grape.

16. Reselect the Brush tool and change the fill color back to green, if
necessary.

17. Drag to paint the bottom grape, making sure to drag over the other
grapes and outside of the grape area as well. When you release the mouse
button, you’ll see that only the selected grape has been painted.

18. Choose Edit→Undo several times to return the grape to its original
color and to deselect it.

19. Finally, you will use the Paint Inside mode to paint the gap between the
grapes. Choose Paint Inside from the Brush Mode drop-down list .

Be careful to click on the
inside of the grape to select

the fill. If you click on the
edge of the grape, you’ll
select the grape’s outline

instead.

18 FlashMX - Level 1 (Windows)

DO
 N

O
T 

DU
PL

IC
AT

E

In
st

ru
ct

or
 E

di
tio

n



20. Select a lighter purple color than the grapes from the Fill color drop-
down list in the Toolbox.

21. Paint over the gap between grapes near the stem. When you release the
mouse button, you’ll see that the gap between the grapes is the only area
that was painted.

22. Paint the other gaps in the grapes.

23. Choose File→Save.

The Eraser Tool
Like the Brush tool, the Eraser tool has several shapes and sizes, as well as
modifiers. However, the Eraser tool is used to remove lines or fills from the
shapes in your Flash movies. The modifiers available for the Eraser tool are listed
in Figure 2-3.

Modifier Description
Erase Normal Eliminates any part of the object covered by the

stroke of the eraser.
Erase Fills Eliminates any fills covered by the stroke of the

eraser.
Erase Lines Eliminates any strokes covered by the stroke of

the eraser.
Erase Selected Fills Eliminates any fills that have been selected by the

arrow tool that are covered by the stroke of the
eraser.

Erase Inside Eliminates gaps or spaces between strokes in the
object.

Figure 2-3: Modifiers for the Eraser tool.

Aside from the different Eraser modes, the Eraser tool also has another option—
the Faucet. When the Faucet is selected, you can quickly erase entire fills or
lines, no matter which Eraser mode you are currently using.

Be sure your initial click is
inside the area you wish to
fill. If parts of the grapes are
also painted, undo to return
them to their original color,
and reposition the brush so
that its starting point is
within the gap.

Lesson 2: Drawing and Painting 19

DO
 N

O
T 

DU
PL

IC
AT

E

In
st

ru
ct

or
 E

di
tio

n



TASK 2B-5:
Erasing Objects with the Eraser Tool

1. Click on the Eraser tool . The eraser modifiers appear in the Options
section of the Toolbox. The default eraser mode is Erase Normal.

2. Drag over the grapes to test out the Eraser tool. In this mode, both the
fills and strokes will be erased.

3. Choose Edit→Undo to return the grapes to their original appearance.

4. Choose the Erase Inside eraser mode .

5. Click on the Eraser Shape drop-down list and select the smallest round
shape.

6. Drag to erase the gaps between the grapes. Similar to the Paint Inside
mode with the Brush tool, the Erase Inside mode erases entire fills.

7. Choose Edit→Undo to return the grapes to their original appearance.

8. Using the Erase Inside mode can be a time-consuming method to precisely
erase the fills in your object, especially if they are numerous. Using the Fau-
cet option, you can quickly and accurately erase fills. Click on the Faucet
button . The cursor changes to a faucet icon.

9. Click in the gaps between the grapes. The fills in the gaps of the grapes
are erased quickly and precisely.

10. Choose Edit→Undo to return the grapes to their original state.

The Paint Bucket Tool
As you have seen, the fill colors for new and existing objects can be changed
using the Colors section of the Toolbox or the Property Inspector. You can also
modify these object properties by using the Paint Bucket tool when working with
fills.

You may want to zoom in on
the grapes to make it easier

to fill between them.
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With the Paint Bucket tool, you can add solid, gradient (bands of color blending
into each other), or bitmap fills to the objects in your Flash movies. Gradients
can blend up to eight colors and can either be composed of linear bands or con-
centric circles. You can further manipulate gradient fills by using the Fill
Transform tool to rotate, skew, change the center point, alter the width, or adjust
the height of a gradient.

Just as the Brush and Eraser tools offered modifiers to adjust how they add or
erase color to an object, the Paint Bucket tool has a Gap Size modifier. The Paint
Bucket tool works on the premise that it fills enclosed areas. Sometimes when
working with an object, you want to fill and area that is not completely enclosed
by an outline. The Gap Size modifier allows you to choose the type of area that
will be filled, from completely enclosed by outlines to areas with large gaps.

TASK 2B-6:
Creating Fills with the Paint Bucket Tool

1. You will use the Paint Bucket tool to fill the bananas in the fruit.fla file.
Select the Paint Bucket tool . The cursor changes to a paint bucket
icon. You use just the tip of the cursor’s “pouring paint” to fill an object.

2. First you will select a color to use for the fill. Click on the Fill color but-
ton and choose a yellow color from the drop-down list.

3. Click inside the top banana with the tip of the cursor. All of the top
banana is filled with the yellow color you selected.

4. Choose Close Large Gaps from the Gap Size modifier drop-down
list.

5. Click inside the tip of the bottom banana. Flash closes the gaps in the
banana and fills only part of it with the yellow color.

6. Because the bananas are already completely enclosed shapes, you will use
the Don’t Close Gaps mode to finish filling the bananas. Choose Don’t
Close Gaps from the Gap Size modifier drop-down list.

7. Finish filling in the rest of the bananas.

gradient:
Bands of color that blend
into each other. In Flash,
gradients can blend up to
eight colors in linear or
concentric patterns.
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8. You have used the Paint Bucket tool to fill an empty object with a solid
color. Next, you’ll begin to work with color gradients, changing the existing
solid fill of the apple to a gradient. Click on the Fill Color button. The
pop-up color palette includes a selection of gradient swatches in its bottom
row.

9. Click to select the red and black gradient.

10. Click in the upper left corner of the apple to add the gradient. The gra-
dient replaces the apple’s solid red fill color.

11. When working with the red-to-black gradient, the red part of the gradient is
concentrated at the point where you clicked with the Paint Bucket tool. You
can use the Fill Transform tool to change the gradient in a variety of ways.
Among other things, this tool allows you to reposition the gradient’s center
point, adjust its width and height, and rotate or skew the gradient. Select the
Fill Transform tool in the Toolbox.

12. Click on the apple. A circle appears around the apple, indicating that the
gradient has been selected. The handles that appear on this selection allow
you to change the appearance of the gradient.

13. The center point of the gradient is indicated by the circular handle in the
middle of the selection. You can move the centerpoint by moving this
handle. Drag the center point handle to reposition it above the upper-
right corner of the white square on the apple.
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14. You can change the width of this gradient by dragging the square handle on
the edge of the selection. Drag the square selection handle to the right to
increase the portion of the apple that is covered by the red center of the
gradient.

15. You can change the radius of a circular gradient by dragging the circular
handle directly beneath the square handle on the edge of the selection. Drag
the circular handle beneath the square handle to the left. This reduces
the area of the apple filled with the red portion of the gradient, and gives the
effect of a smaller light source shining on the apple.

The Ink Bottle and Eyedropper Tools
The Ink Bottle tool is handy for changing the stroke attributes of existing lines.
Once a shape has been drawn, this tool makes it easy to modify the appearance
of the lines which compose the shape. Once you have selected the Ink Bottle
tool, you can set the attributes for a line in the Property Inspector, just as you did
when working with other drawing tools.

Another helpful tool for modifying fill or stroke appearance is the Eyedropper
tool. With this tool, you can easily duplicate the fill or stroke in an already exist-
ing object and apply it to a new one. The tool will pick up whichever attribute
you click on in an object, either a fill or a stroke, which will then remain the
active fill or stroke for whatever tool you are using.

TASK 2B-7:
Modifying Strokes with the Ink Bottle and Eyedropper
Tools

1. In this task, you’ll modify the line attributes of the pineapple. Click on the
Ink Bottle tool .

2. In the Property Inspector, choose a brown color from the Stroke Color
drop-down list.

3. Select 3 as the line size in the Stroke Height field in the Property
Inspector.

4. Choose Solid from the Stroke Style drop-down list.

5. Now you’re ready to add these settings to the lines in the pineapple. Click
with the tip of the Ink Bottle tool on one of the lines in the leaves of the
pineapple. The lines are modified to take on the characteristics you selected.
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6. Next, you’ll apply the new attributes to the crisscrossed lines in the body of
the pineapple. Click on one of the lines in the body of the pineapple.
Flash changes only the section of the line you clicked on.

7. In order to change the attributes of all the lines at once, you’ll need to select
them. Click on the Arrow tool.

8. Double-click on one of the lines in the body of the pineapple. All of the
lines are selected.

9. Now you’re ready to copy the new line attributes. From the Toolbox, select
the Eyedropper tool .

10. Click on the lines in the pineapple’s leaves.

11. Click with the tip of the Ink Bottle tool on one of the lines in the body
of the pineapple. The Eyedropper tool automatically changes the properties
of the lines you’ve selected in the body of the pineapple to match the lines
in the leaves.

12. Close the file and save the changes.

Topic 2C
Creating Custom Colors, Gradients, and Line
Styles
Flash offers a wide range of colors, gradients, and line styles for you to choose
from when creating Flash movies. However, often you will need to create a cus-
tom color, gradient, or line style for the movie you are working on. Luckily, even
in those cases, Flash makes creating the exact look you need an easy task.
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The Color Mixer Panel
When you need to create or edit a solid color you use the Color Mixer panel,
where you can specify colors by their RGB (Red, Green, Blue), HSB, or hexa-
decimal values. You can also use the Alpha mode to set the level of transparency
for a color. If you have an object selected on the Stage before you begin to make
changes in the Mixer panel, the color modifications you make will be applied to
that selected object.

It is important to use caution when using custom colors in a movie. When you
create a custom color, Flash may end up combining other colors to create a Web-
safe color close to the one you’ve defined. Using this approximation may degrade
the quality of your images.

TASK 2C-1:
Creating a Custom Color Swatch

1. You will create several custom colors to use in your Jammin’ Juice banner
ad. Navigate to and open the jammin_banner.fla file in the Flash MX
Level 1 Data folder.

2. Expand the Color Mixer panel.

3. You will add several colors by specifying their RGB values. These are colors
taken from an image you will use later in your banner ad. Choose Solid
from the Fill Style drop-down list, if necessary. Type 163 in the Red
field, 57 in the Green field, and 124 in the Blue field. A magenta color is
created.

4. Next, you will add the color to the Color Swatch panel, so that it can be
used in your movie. Click on the triangle in the upper right corner of the
panel. The Color Mixer drop-down list appears.

5. Choose Add Swatch.

6. You can verify that your color has been added by viewing the Color
Swatches panel. Expand the Color Swatches panel. The color has been
added in the bottom left corner of the panel.

7. There are three other colors you want to add for the movie you are working
on. Type 143, 65, 147 in the RGB values to create a violet color. To add
it to the Color Swatches panel, click in the space below the other colors.

RGB value:
Color that is determined by
the levels of red, green, and
blue that compose it.

HSB value:
Color that is determined by
hue, saturation, and
brightness settings.

hexadecimal value:
A unique six-digit code that
is assigned to a specific
color value. Used by most
Web sites and HTML pages.
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8. Type 196, 170, 120 in the RGB values to create a light brown color and
add it to the Color Swatches panel.

9. Type 61, 70, 126 in the RGB values to create a dark blue color and add
it to the Color Swatches panel.

10. As you create new colors, you may want to use them in other movies. You
could save this list as separate colors list or you could set it as the default
colors list when Flash opens. Because you didn’t eliminate any of the origi-
nal Web-safe colors and only added a few more, you will set it as the default
color panel for future movies. Click the triangle in the upper right corner
of the panel. The Color Swatches drop-down list appears.

11. Choose Save as Default. A dialog box appears asking if you are sure you
want to save the current colors as the default colors for creating new
documents.

12. Click Yes.

Custom Gradients
Just as you can add custom colors to the Flash palette, you also have the option
of adding custom gradients. While the process of creating a gradient is a little
more complex, Flash still makes this a relatively easy task. To create a custom
gradient, you’ll work with the Color Mixer Panel. The gradient controls here
allow you to choose from linear or radial types, to specify which colors will be
included, and to add or remove colors from the gradient.

TASK 2C-2:
Creating a Custom Gradient Swatch

1. You will create several custom gradients to use for a bottle cap in the
Jammin’ Juice banner ad later. Choose Radial from the Fill Style drop-
down list in the Color Swatches panel. A black and white gradient bar
appears.

2. When you work with gradients, the pointers on the gradient bar determine
what colors are included in the gradient, as well as the amount of each color
in the gradient. To change the color of the pointer, you use the square to the
left of the Fill Style drop-down list. You will first change the color of the
left pointer to dark blue. Choose the custom dark blue color you created
from the Color drop-down list. The gradient starts with the dark blue color.
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3. Next you will change the color of the right pointer. Click on the right
pointer to activate it.

4. Choose the custom magenta color you created from the Color drop-
down list. The gradient now changes from blue to magenta.

5. You will add the two other custom colors you created to the gradient. Posi-
tion the cursor anywhere below the gradient bar until there is a plus
sign icon and click.

Another pointer appears below the gradient bar, with the shade of blue or
magenta currently on the bar at that point in the gradient.

6. Change the pointer to the custom violet color.

7. Finally, you will add the light brown color to the gradient. Click to add a
pointer between the violet and magenta pointers. Again, the pointer takes
on the color that was already in gradient.

8. Change the pointer to the custom light brown color.

9. You can adjust the look of your gradients by adjust the position of the
pointers. Move the violet pointer about 1⁄2″ to the right of the dark blue
pointer, if necessary. The darker blue color is shortened in the gradient.

10. Move the light brown pointer about 1⁄2″ to the left of the magenta
pointer, if necessary. The magenta color is shortened.

11. You are finished creating your gradient, and will add it to the Color
Swatches panel. Choose Add Swatch from the Color Mixer drop-down
list. The gradient now appears in the Color Swatches panel.

12. You will now create a new gradient for the bottle cap using the custom
magenta color. The gradient will change from a lighter shade of the magenta
color to a darker shade. First you will need to create the darker and lighter
shades of magenta. Choose Solid from the Fill Style menu.

13. Select the custom magenta color from the Fill Color drop-down list.

14. Drag the Brightness control down so that it is approximately two thirds
of the way down on the scale.

15. Add the swatch to the Color Swatches panel.

16. Using the same magenta color hue, you will create a lighter color. Drag the
Brightness control up so that it is approximately one third of the way
down the scale.
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17. Choose Add Swatch from the Color Mixer drop-down list.

18. You will now create the gradient using the two colors you just created.
Choose Linear from the Fill Style drop-down list. The gradient bar
appears with the four pointers from the previous gradient.

19. You will remove the two pointers in the middle of the gradient. Position the
cursor over the second pointer and drag down to remove it from the
gradient.

20. Position the cursor over the pointer in the middle of the gradient bar
and drag down to remove it.

21. With the left pointer selected, choose the darker magenta color you just
created from the Fill Color drop-down list.

22. Click on the right pointer.

23. Choose the lighter magenta color you just created from the Fill Color
drop-down list.

24. Choose Add Swatch from the Color Mixer drop-down list.

25. Choose File→Save.

Custom Line Styles
Not only does Flash provide tools for creating custom colors and gradients, it
also offers tools for creating custom line styles. When working with lines, you’ll
use the Property Inspector to set attributes. To create a custom line style, you’ll
use the Line Style dialog box.

TASK 2C-3:
Creating a Custom Line Style

1. To view the stroke properties for a line, you need to first select the line.
Using the Pointer tool, double-click on the outline of the “j” on the
jammin_banner.fla banner ad to select the outline around the entire
letter.

2. You will create a custom stroke for the outline. Click the Custom button in
the Property Inspector. The Stroke Style dialog box appears.

3. In the Stroke Style dialog box you can change the attributes of a line to a
further extent than in the Property Inspector. The attributes change depend-
ing on which line style you choose. You will chose the Stipple line style,
and make the line slightly darker by changing the dot size and the dot
variation. Choose Stipple from the Type drop-down list.

4. Choose Medium from the Dot Size drop-down list. The changes appear in
the preview window.
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5. Choose Random Sizes from the Dot Variation drop-down list. Again, the
changes appear in the preview window.

6. Click OK.

7. Deselect the outline by clicking anywhere on the page to see the changes.

8. Close the file and save any changes.

Summary
In this lesson, you used Flash’s basic drawing and painting tools to create
and modify some simple shapes. You also worked with strokes and fills to
modify existing shapes. Finally, you created custom fills and strokes for use
in your Flash movies. As you can see, Flash provides many tools which are
useful for creating custom graphic looks and effects.

Lesson Review
2A How do vector and raster graphics differ? What are the strengths and

weaknesses of each?

Vector graphics are defined by mathematical equations. They have smaller
file sizes, are resolution independent, and can be resized without distortion.
They are editable within Flash. Editing complex vector graphics can be diffı-
cult because they are composed of smaller graphic objects. Raster graphics
are composed of grids and pixels. They have large file sizes. They tend to
become distorted when resized and they are resolution dependent. Raster
graphics can be detailed and complex.
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2B Name three Flash drawing and painting tools and list their primary
functions.

Any three of the following: The Pencil tool is used for drawing free form
shapes, lines, and curves. The Pen tool is used to draw precise paths with
straight lines or smooth curves. The Line tool is used to draw horizontal,
vertical, and diagonal lines. The Oval tool is used to draw ovals and circles.
The Rectangle tool is used to draw rectangles and squares. The Brush tool is
used to draw freehand shape or add fills to existing shapes. The Eraser tool
is used to remove lines or fills. The Paint Bucket tool is used to add or
modify fills to an object. The Ink Bottle tool is used to add or modify the
strokes of an object.

Which tool will pick up strokes or fills for an object and apply them to
another object?

The Eyedropper tool will pick up strokes or fills for an object and apply
them to another object.

2C Which panels are used when creating custom colors, gradients, and line
styles?

The Property Inspector and the Color Mixer panels contain the options
required to create custom colors, gradients, and line styles.
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Manipulating Objects

Overview
Flash objects have certain rules which govern their behavior. Learning these
rules will help you when it comes time to select an object, deal with object
interaction, transform an object, group objects, or import artwork. In this
lesson, you’ll experiment with all of these situations.

Objectives
In order to work with objects in Flash, you will:

3A Edit and reposition objects using the selection tools.

Since most Flash objects are actually made up of a collection of objects,
learning how to select them can be difficult. Once you’ve had some prac-
tice, you’ll know which selection tool to use in a particular instance.
You’ll also see how easy it is to edit all or part of an object once it has
been selected.

3B Manipulate Flash objects on a single layer to achieve various effects.

When working with multiple objects on a single layer, you can change
the interaction between the objects.

3C Scale, rotate, skew, group, and ungroup objects.

Scaling, rotating, skewing, and ungrouping objects allows you to create
even more complex and interesting objects.

3D Import and modify artwork into a Flash file.

While Flash offers a variety of tools for creating original graphics, you
may find the need to import artwork created in other programs. You will
import a bitmap image into Flash and convert it to a vector image.

Data Files
object practice.fla
bottle.gif

Lesson Time
1 hour

LESSON

3
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Topic 3A
Selecting Objects
An essential part of learning how to manipulate objects is first understanding how
to select them. Objects in Flash can sometimes behave in ways you don’t expect.
Practicing with the Flash selection tools will help you to become more familiar
with these unpredictable behaviors and, more importantly, how to work with
them.

The Arrow Tool
The Arrow tool is useful for making straightforward selections. With the Arrow
tool, you can click on an object to select it, or you can drag to draw a rectangular
border, or selection marquee, around the object you wish to select. Once an
object is selected, you can move, copy, cut, or paste it.

TASK 3A-1:
Selecting Objects with the Arrow Tool

1. You will work with some existing objects for this task. Navigate to and
open the object practice.fla file in the Flash MX Level 1 Data folder.

2. Each of the shapes in this document contains both a fill and an outline. In
Flash, with any given shape, you can select either the fill, or the outline, or
both. Select the Arrow tool , then click on the outline of the yellow
circle. Only the outline of the circle is selected.

3. Click on the center of the yellow circle. This selects only the circle’s fill.

4. Click on the center of the circle again and drag to the right. Only the
circle’s selected fill moves.

selection marquee:
A rectangular area, created
with the Arrow tool, which

selects the objects within its
borders.
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5. If you wish to move an object more precisely, you do have the option to
keep its movement along a horizontal or vertical line, or on a 45-degree
diagonal, by using the [Shift] key. Hold down the [Shift] key, then drag
the yellow circle down diagonally. The circle’s fill moves along a perfect
45-degree diagonal.

6. You can also move the selected object by one pixel using the arrow keys on
the keyboard. Press the left arrow key several times to move the circle’s
fill to the left several pixels.

7. Choose Edit→Undo as many times as necessary to return the circle to
its original position.

8. Next, you’ll work with selecting the triangle shape. Click on the triangle’s
outline. Only the segment on which you clicked is selected. This is because
the triangle is composed of multiple line segments.

9. Double-click on the outline of the triangle. This selects the entire outline
of the object, whether or not it’s made up of multiple line segments.

10. Double-click on the fill of the triangle. Double-clicking on the fill of an
object selects the entire object, both fill and outline.

11. You can also select more than one object at a time. Click on the fill of the
yellow circle.

12. Hold down the [Shift] key and then double-click on the green square.
Both the yellow circle’s fill and the green square are selected.

13. Drag to move the square lower on the page. The circle’s fill moves as
well.

14. Choose Edit→Undo to return the shapes to their original positions.

15. Click on any empty part of the Stage to deselect the objects.

16. Another way to select multiple objects at once is with a selection marquee.
Place the cursor to the left above the yellow circle and drag down and
to the right to create a rectangular selection marquee around both the
circle and the red triangle then release the mouse button. The circle and
the triangle, fills and outlines included, are selected.

17. Once an object is selected, you can use the copy and paste commands to add
copies of it to the Stage. Double-click on the blue rectangle to select it.

18. Choose Edit→Copy.

19. Choose Edit→Paste. Flash adds a copy of the rectangle to the center of the
visible Stage area. You can also make a copy

using the Duplicate
command.
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20. If you’d rather paste a copy of a shape in the same place as the original,
which is especially useful when working with layers, Flash offers that option
as well. Choose Edit→Paste in Place. Flash adds a copy of the rectangle
directly on top of the original.

21. Choose Edit→Undo as many times as necessary to remove the rectangle
copies.

The Lasso Tool
Previously, you used the Arrow tool to draw a marquee around two objects next
to each other, but suppose you wanted to select objects that weren’t lined up
quite so neatly? For example, if you were to use the Arrow tool to select the tri-
angle and the oval shown in Figure 3-1, you’d wind up also selecting parts of the
rectangle and the square.

Figure 3-1: The Lasso tool is useful when working with multiple objects.

When you need to select an irregularly shaped area, you can use the Lasso tool.
This tool allows you to make free-form selections by drawing a loop around the
objects you wish to select. You can also use the Lasso tool in Polygon mode to
make straight-edged selections.

TASK 3A-2:
Selecting Objects with the Lasso Tool

1. Select the Lasso tool .

2. Drag around the red triangle and the orange oval to create a selection.
The Lasso tool allows you to tailor your selection to fit the area.

3. When you release the mouse button, both the triangle and the oval are
selected. Choose Edit→Deselect All.
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4. You’ve been using the Lasso tool in its normal mode. This tool also has a
Polygon Mode that is useful for creating irregularly shaped selections with
straight edges. In the Options section of the Toolbox, click on the Polygon
Mode button .

5. Previously, you’ve selected entire fills, outlines, or objects. You can also
select parts of objects. To demonstrate this, you’ll split the orange oval in
half with a zigzag selection. Click on the Stage above the middle of the
oval and drag down slightly into the oval.

6. Click again to create a line segment.

7. Continue to drag and click at each turning point to create zigzagging
line segments through the oval.

8. To finish your selection, drag and click to draw line segments connecting
the beginning and end of the jagged line.

9. When you have finished creating the selection, double-click to complete
it.

10. The selection is complete. Click on the selected half of the oval and drag
it to the right.

11. Close the file and save the changes.
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Topic 3B
Object Interaction
In Flash, objects on a single layer will interact with one another in a variety of
ways, causing them to split or combine under different circumstances. When
objects overlap, there will always be an interactive effect. For example, when you
draw a new object on top of an existing object, the new object will remove the
portion of the old object where they overlap once you deselect it. Overlapping
can cause other effects as well. In order to work efficiently, you’ll need to
become familiar with these object interaction behaviors.

Each object that you add to the Stage is given a place in the stacking order. The
first objects you add to the Stage will be lower in the stacking order than those
you add later. This means that should you position the first object in the same
space as the last object, the last object will obscure the first. Understanding stack-
ing order helps you to know how objects will appear when they overlap.

TASK 3B-1:
Working with Overlapping Shapes

1. In this activity you will create a bottle cap for the Jammin’ Juice banner ad,
but first you will experiment with how objects interact with one another.
Navigate to and open the jammin_banner.fla file in the Flash MX Level
1 Data folder.

2. You will create a larger circle which will serve as the bottom layer of the
bottle cap. Click the Oval tool .

3. Select the light to dark magenta gradient fill and no stroke in the Color
section of the Toolbox.

4. Hold down the [Shift] key and drag to create a circle to the right of the
“j,” approximately six grid squares in diameter.

5. Draw a second circle with a solid magenta fill, slightly smaller and to
the right of the first.

6. Use the Arrow tool to select the second circle.

stacking order:
The order in which items

appear, based on the order
they were placed on the

Stage. Objects placed on the
Stage later will be higher in
the stacking order and will
obscure objects already on

the Stage.
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7. Drag the second circle over the first. When you release the mouse button,
the second circle is still selected.

8. As long as an object is still selected, it will not interact with other objects
around it. However, once it is deselected, if you remove it, whatever was
covered of the other object will also be removed. Click on an empty space
on the Stage to deselect the second circle.

9. Drag the inner circle away from the first. The section of the first circle
that was covered up is removed.

10. Click Edit→Undo to place the second circle on the first. The second
circle is still selected.

11. It is possible to undo your actions to the point where you first placed the
object, so that you can move it without disturbing other objects. Click
Edit→Undo. The inner circle is deselected.

12. Click Edit→Undo again. The inner circle is selected and at the point when
you had just placed it.

13. Drag the inner circle off the larger circle. The larger circle is not affected
by the inner circle.

14. You will return the smaller circle on top of the larger one, and add two oth-
ers for the bottle cap. Select and drag the smaller circle over the larger
one.

15. While the inner circle is still selected, use the arrow keys on the key-
board to center it on the larger one.

16. Draw another circle with the magenta gradient fill, approximately four
and a half grid squares in diameter, to the right of the other circles.

17. You will move the gradient so that it goes in the opposite direction of the
first circle. Click the Fill Transform tool and click on the last circle. Gra-
dient bounding lines appear around the circle.
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18. Drag the gradient rotation handle so that the gradient starts light on the
left and gets darker.

19. Click the Arrow tool and select the circle.

20. Drag the circle over the other two and use the arrow keys to center it.

21. Click on an empty space on the Stage to deselect the circle. You will cre-
ate the last circle for the bottle cap in a later activity.

22. Choose File→Save.

Line-to-Line Interaction
Working with lines on the same layer is a little different than working with
shapes. You have somewhat more control with line segment behavior than you do
with shapes. Lines aren’t affected by overlapping the way shapes are; they are
controlled by the points of intersection and the stroke characteristics they have.
For example, two lines which intersect, but have different stroke attributes will be
broken up at the intersection, but can still be selected as their individual, continu-
ous lines. As you will see, however, once the stroke characteristics for part of a
line have been changed, the ability to select the whole line is no longer available.

TASK 3B-2:
Intersecting Lines

1. You will start by drawing a line with the pen tool, but first you want to
zoom in on the screen to view the line you are creating better. Choose
200% from the Zoom drop-down list.

2. Select the Pen tool.

3. Set the line to a blue color and four points in size using the Property
Inspector.

4. Position the cursor at an intersection of a horizontal and vertical grid
line at the top of the Stage and click to place an anchor point.
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5. Position the cursor two grid squares directly below the first.

6. Drag down and to the left to create a curve that is similar to part of a
circle and release the mouse.

7. Click to place a third anchor point two grid squares below the second.
Flash creates an equal, but opposite curve to the under the first.

8. Next you will draw a straight line, perpendicular to the first. Using the Line
tool, draw a horizontal line approximately four grid squares long, and
format it light green and size 3.5 in the Property Inspector.

9. Click on the Arrow tool. The second line is selected.
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10. Drag the second line over the first.

11. Click on the Stage to deselect the line.

12. Click on the blue line. Only one side of the line is selected.

13. Double-click on the line. Both parts of the line are selected.

14. Lines are not affected the way shapes are, in that when you remove a line, it
does not eliminate the part of the other line it covered up. Drag the blue
line away from the light green line. Both lines are intact.

15. Drag the blue line back over the light green and deselect it by clicking
somewhere on the empty Stage.

16. Click on one end of the light green line. Only one half is selected.

17. Change the color of the line to black, size 5. Only the half of the line that
was selected is changed.

18. Double-click on the black line you just changed. Only the segment you
changed is selected. When you changed the properties of the one segment,
the line was divided.
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Object Combinations
Now that you have seen the difference between how lines and shapes interact,
you are ready to look at how objects interact when they are combined. Because
lines and shapes interact similarly when they are selected in combination with
other objects, you will work with the lines you used in the last activity. The prin-
ciples about object interaction that you will use on these lines also apply to shape
objects.

TASK 3B-3:
Combining Objects

1. Once objects which intersect or overlap on the same layer have the same
attributes, Flash automatically combines them. You will change the stroke
attributes of the lines you created in the last activity. Click on any of the
lines you created.

2. Change the line color to purple, size 1.

3. Select the Eyedropper tool and click on that line to set the stroke
attributes for the Ink bottle tool.

4. With the Ink bottle tool, click on each of the other lines. All the lines you
drew are purple, size 1.

5. Click on any of the lines with the Arrow tool. Only one segment is
selected.

6. Double-click on any segment using the Arrow tool. All of the lines are
selected. Flash has automatically combined them because of the similar line
attributes. This is also true of shapes. Once a fill, gradient, or bitmap is
applied to several different selected and overlapping shapes, they are auto-
matically combined.

Line and Shape Interaction
Finally, you will take a look at how shapes are affected when they are intersected
with lines. Just as shapes and lines break down into separate segments when they
overlap or intersect, shapes are broken into separate parts when a line intersects
them. This is useful when creating more complex shapes or varying fill within a
shape. It is also useful when animating a shape, as it allows you to quickly and
efficiently break that shape apart.
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TASK 3B-4:
Using a Line to Divide a Shape

1. You will create the final circle for a bottle cap for the Jammin’ Juice banner
ad. Using the Oval tool, draw a circle four grid squares in diameter, with
no fill and purple, size 1 outline.

2. You will use the “S” shaped segment you created in the last activity to inter-
sect the circle, but first you need to delete two of the segments. Select one
segment of the horizontal line.

3. Press [Backspace] to delete it.

4. Do the same to delete the left horizontal segment, leaving you with the
original “S” shaped line.

5. Drag the line to the center of the circle you just created, so that the ends
of the line segment line up with the circumference of the circle. As with
any other shape interaction, as long as the line is still selected the circle is
not yet affected.

6. Click on the Stage to deselect the line.

7. Now that the line intersects the circle, you have the ability to move, resize,
reshape, or change the appearance of either side, independent of the other.
Select the Paint Bucket tool.

8. Choose the four color custom gradient you created from the Fill Color
drop-down list.

9. Apply the gradient to the right half of the circle. The gradient appears in
the right half of the circle only.

Clicking near the center of
the circle will set the center
of the radial gradient in the

center of the circle.
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10. The separation of the two sides is not dependent on the line segment staying
in place. Select and drag the line segment outside of the circle. The parts
of the circle you created remain.

11. Choose File→Save.

Topic 3C
Transforming and Grouping Objects
There are several methods for transforming an object. First you can use the
Transform tool, click on the object, and freely rotate or scale the object in the
direction you like. Second, you can choose from several options in the Modify
menu, including Free Transform, Rotate and Skew, Scale and Rotate, Rotate 90°
Clockwise or Counter-clockwise. Finally, you can use the Transform panel to
modify your objects.

When you scale an image with the Transform panel, you have the option to
enlarge or reduce its size horizontally, vertically, or both according to
percentages. To rotate an object, you simply enter the angle degree to which you
wish to rotate it. The object then rotates around its registration point, or center
point. To skew or slant an object along either its vertical or horizontal axis, you’ll
enter a value to represent the angle at which you wish to skew.

TASK 3C-1:
Transforming Objects

1. In this activity, you will complete the center of the bottle cap for the
Jammin’ Juice banner ad. First you will rotate the “S” line you created to
create a pinwheel for the center of the bottle cap. Select and duplicate the
“S” line. The second line you created is still selected.

2. Expand the Transform panel.

3. Type 120 in the Rotate field.

registration point:
The center point of an object.

As students work through
this activity, suggest that
they work in an area of the
screen that will not interfere
with the shapes they have
already created but won’t be
using in this activity, the “j”
and the concentric circles
for the bottle cap.
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4. Drag the second line over the first so that their center points are
aligned.

5. With the second line still selected, duplicate the line again. A third line is
added to the Stage, to the right of the second line, and is selected.

6. You will rotate the third line. Type 240 in the Rotate field.

7. Drag the third line over the first two so that their center points are
aligned.

8. You will place the pinwheel over the circle you created in the last activity,
but first you will fill the whole circle with the gradient fill, so that you don’t
have to worry about lining up the “S” line again. With the arrow tool,
select the fill on the right half of the circle and press Backspace.

9. Use the Paint Bucket tool to fill the circle with the four color custom
gradient.

10. Select the pinwheel lines by double-clicking anywhere on it and drag it
over the circle, so that the lines are completely contained by the circle,
then deselect the lines.

11. To finish the pinwheel effect, you will fill every other swirl with white.
Select the Paint Bucket tool.

12. Choose white from the Fill Color drop-down list and Close Large Gaps
from the Paint Bucket Options panel.

You may need to use the
arrow keys on the keyboard

to adjust the lines
appropriately.
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13. Click in every other space in the circle.

14. With the Arrow tool, select all the lines in the pinwheel and the circle’s
outline and delete them.

15. You are ready to add the fruit you worked on in an earlier lesson to the
pinwheel. Navigate to and open the fruit.fla file in the Flash MX Level 1
Data folder.

16. Select the grapes and copy them.

17. Choose Window →jammin_banner.fla to the return to the
jammin_banner.fla file and paste the grapes. The grapes are selected,
however, they are much too large.

18. You will use the Transform panel to scale the grapes to an appropriate size.
Expand the Transform panel, if necessary.

19. You want to make sure the grapes retain their original proportions, so first
you will make sure that any changes you make to the height are also made
to the width. Check the Constrain checkbox, if necessary.

20. Type 17 in the Height field. The Width field is automatically changed, as
well, and the grapes are scaled down in size.

21. You will rotate the grapes so they fit in the swirl. Click the Rotate radio
button, if necessary, type 15 in the Rotate field, and press [Enter].

22. Drag the grapes to the top white swirl in the pinwheel.

23. Return to the fruit.fla file, copy the bananas and orange, and paste them
in the jammin_banner.fla file.

You may want to zoom in to
see the lines more clearly.

You may need to zoom out
to view the whole grapes
object.

Depending on how the
pinwheel fits in your circle,
you may need to use a
different angle. Positive
angles rotate the object
clockwise, and negative
angles rotate it counter-
clockwise.
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24. Make sure both objects are not touching any other objects, and click on
an empty part of the Stage to deselect them.

25. This time you will scale the objects down using the Free Transform tool.
Select the Free Transform tool in the Toolbox.

26. Drag around the orange to select it. A bounding box appears around the
orange. Similar to the gradient handles you used earlier, the transform
bounding box allows you to freely rotate and scale the shape.

27. When you use the Transform tool, holding down the [Shift] key while
resizing the object will constrain the original proportions of the shape. Hold
down the [Shift] key and drag any corner of the orange’s bounding box
to reduce it, so that it will fit in a swirl of the pinwheel.

28. Drag the orange into one of the swirls of the pinwheel.

29. Finally, you will add the bananas to the pinwheel. Drag to select the
bananas.

30. In the Transform panel, type 17 in the height field.

31. Use the Transform tool to rotate the bananas until they fit in the third
white swirl, then drag the bananas to the pinwheel.

32. Often, scaling an object will impact its appearance. In the bananas and
orange shapes you scaled down, the lines are to thick, obscuring the overall
image, so you will reduce the stroke properties for all the shapes. With the
arrow tool, drag to select the entire pinwheel. All the swirls and fruit are
selected.

33. In the Property Inspector panel, select .25 for the line width and dese-
lect the pinwheel. The bananas and orange are more clear.

34. Choose File→Save.

You may want to zoom out in
order to move the bananas

and orange into the work
area.
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Grouped Objects
When you combine several simple objects together to create a more complex
object, it’s easier to work with the complex object if you group its parts together.
Once objects are grouped together, they will move and transform as one object.
This way, you won’t have to worry about leaving part of a complex creation out
when moving it, transforming it, and animating it on the Stage.

TASK 3C-2:
Grouping and Ungrouping Objects

1. To complete the bottle cap for the Jammin’ Juice banner ad, you will move
the pinwheel and fruit on to the concentric circles you created earlier. Using
the Arrow tool, drag the pinwheel onto the center of the circles you cre-
ated earlier. Since the objects around the pinwheel are not grouped, only the
pinwheel moves, leaving the white background and fruit behind.

2. Choose Edit→Undo to return the pinwheel to its original position.

3. First you will select all the objects that make up the center of the bottle cap.
Using the Arrow tool, drag a selection marquee around the white circle,
pinwheel and fruit. All the objects are selected.

4. Choose Modify→Group. A blue bounding box appears around the bottle
cap center, indicating that all the individual objects will now act as one
grouped object. As long as they are grouped they can no longer be individu-
ally selected or modified.

5. You will drag the center of the bottle cap over the other parts. Drag the
center of the bottle cap over the other concentric circles you created.

6. You want the inside rim of the bottle cap to equal the outside rim, so you
will scale the center to enlarge it. Since it is already selected, type 105 in
the Height field in the Transform panel and press [Enter].
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7. Adjust the center so that the rim around it is even.

8. Finally, because you will be animating the bottle cap as a whole later, you
want to group all of the circles with the center. With the Arrow tool, drag
to select the whole bottle cap.

9. Choose Modify→Group. A bounding box appears around the entire bottle
cap, and it can be moved as one object.

10. Close the file and save any changes.

Topic 3D
Bitmap Images
Flash provides a complete development environment for creating original artwork
from scratch. Flash allows you to import several different file types. Although
Flash is a vector-based program, you can also import bitmap artwork into your
Flash movies. When importing a bitmap file, you can choose from the BMP
(available to Windows users only), PICT (available to Macintosh users only),
JPEG, GIF, and PNG formats.

Once a bitmap is in your Flash document, you can edit it either as a bitmap, you
can convert it to a vector image, or you can opt to launch an external image edi-
tor such as Macromedia Fireworks or Adobe Photoshop. To edit a bitmap within
Flash, you must first break it apart. You can then use the Flash drawing and
painting tools to work with the pixels within the image. Converting a graphic to a
vector image gives you greater control when modifying it and reduces the size of
the file.

You can use Flash to scale, rotate, flip, or skew an imported bitmap. If you wish
to make further modifications to an imported bitmap, you may find it easier to
convert a bitmap into a vector graphic, which Flash can do as well. Doing this
gives you greater control over the object. Another advantage of converting a
bitmap to a vector graphic is the vector graphic’s smaller file size.
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The Trace Bitmap command allows you to convert bitmaps into vector graphics.
The Trace Bitmap dialog box provides settings for several graphic aspects. The
Color Threshold field sets guidelines for converting colors. If the difference
between two pixels’ RGB color values is less than the color threshold setting you
create, then the two pixels are considered the same color. When you increase the
Color Threshold value, you decrease the number of colors (and consequently, the
number of shapes) that will appear in the converted graphic. The Minimum Area
field determines the number of surrounding pixels to compare when selecting a
color for a particular pixel. This setting will determine the smallest possible vec-
tor shape size once the bitmap object is converted. The Curve Fit setting allows
you to specify how smoothly the outlines of finished shapes will be created. The
Corner Threshold field asks you to specify whether sharp edges should be
retained or smoothed out.

It’s best to convert only simple bitmaps into vector graphics. Trying to convert a
more complex bitmap with a wide range of colors can have less than satisfactory
results. When Flash converts a bitmap to a vector graphic, it converts pixels of
similar colors into vectors. A bitmap with many colors will turn into a vector
graphic composed of many objects. This can make the graphic difficult to edit,
and can also increase, rather than decrease, its file size.

TASK 3D-1:
Importing and Modifying Bitmap Graphics

1. In this activity you will import a GIF image of a bottle and convert it to a
vector image. Choose File→New.

2. Choose File→Import. The Import dialog box appears.

3. Navigate to the bottle.gif file in the Flash MX Level 1 Data folder.

4. Click Open. The bottle image appears on the Stage with a grey band around
it, indicating that it is a bitmap image.

5. Click on a blank spot of the Stage to deselect the imported image.

6. Since this image is a simple line drawing, you might want to add some color
to it. From the Toolbox, select the Paint Bucket tool.

7. Choose a light brown color from the Fill Color drop-down list.
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8. Click in the neck of the bottle. The Paint Bucket tool doesn’t work because
you cannot edit imported bitmap images in Flash. In order to add a fill color
to this object, you’ll need to convert it to a vector graphic.

9. Before you convert the bottle object, you should zoom in to get a good look
at the bitmap graphic up close. Zoom in to 200%. You can see the pixila-
tion of the bottle.

10. Return to 100% magnification, and select the bottle. Choose Modify→
Trace Bitmap. The Trace Bitmap dialog box appears. The Color Threshold
setting sets guidelines for converting colors. If the difference between two
pixels’ RGB color values is less than the color threshold setting you create,
then the two pixels are considered the same color. When you increase the
Color Threshold value, you decrease the number of colors (and consequently,
the number of shapes) that will appear in the converted graphic. The Mini-
mum Area setting determines the number of surrounding pixels to compare
when selecting a color for a particular pixel. The Curve Fit setting deter-
mines how closely the shapes created by the trace follow the original
bitmap. The Corner Threshold setting determines how much a curve must be
bent before it would be considered a corner.

11. To accept the default settings, click OK. Flash converts the bottle to a vec-
tor image, and the entire object is selected.

12. Click on a blank spot of the Stage to deselect the bottle.
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13. Click on the left of the bottle to select it. Only the individual part of the
bottle on which you clicked will be selected. This is because the bitmap has
been converted to several vector shapes.

14. Click on a blank part of the Stage to deselect the bottle.

15. You’re ready to add a fill color to the bottle. Select the Paint Bucket tool.

16. Click on the Fill Color button and select a light brown color from the
pop-up palette, if necessary.

17. Click inside the bottle. The fill color is added to the bottle.

18. Choose File→Save and save the file as bottle.fla in the Flash MX Level 1
Data folder.

Summary
In this lesson, you selected objects using the Arrow and Lasso tools. You
experimented with line and shape interaction, and used a variety of Flash
options to transform and group objects. You also import a bitmap image into
a Flash document and converted that image to a vector graphic.
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Lesson Review
3A How can you select an object in Flash when it is actually composed of

two or more objects?

If the object is composed of a outline and a fill, double-clicking on the
object will select both objects. You can also use the Arrow tool or Lasso tool
to create a selection marquee. Finally, you can hold down the [Shift] key
while clicking on different objects.

3B How does shape-to-shape interaction differ from line-to-line interaction
in a single layer document?

When shapes overlap other shapes, the shape properties are automatically
affected regardless of their fill. Lines retain their separateness as long as
their stroke properties are different, although intersecting lines create line
segments at the points of intersection. When the stroke properties are the
same, the lines are combined, although the segments are still accessible.

3C What are the three features, tools, or commands you can use in Flash to
transform objects?

You can transform objects in Flash with the Transform tool, the Transform
panel, or the Modify menu.

3D Why might you want to convert an imported bitmap image into a vector
graphic? When wouldn’t you want to convert a bitmap to vector?

You might want to convert an imported bitmap image because vector graph-
ics have smaller file sizes than bitmaps and can be much easier to edit in a
Flash production. However, converting a complex bitmap image, such as one
that contains a wide range of colors, can result in a complicated group of
vector shapes. This can make the image diffıcult to edit and actually increase
its file size.
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Working with Text

Overview
You will probably want to add text to your Flash movies. Text blocks and
text fields allow you to add information and interactivity to your movie.
Text can also be broken apart to use in animations or develop as a graphic
element in your movie.

Objectives
In order to add text to your Flash movies, you will:

4A Create text blocks.

Text is a vital component of content created for the Web. The simplest
way to add text is with a text block.

4B Convert text into shapes by breaking it apart.

Converting text into shapes allow you to create visual effects that aren’t
possible with plain text.

Data Files
jammin_banner.fla

Lesson Time
45 minutes

LESSON

4
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Topic 4A
Text Blocks
While Flash may be primarily thought of as a graphic development tool, you’ll
certainly find the need to add text to the movies you develop. Variable and fixed
width text blocks are the most basic way to add text to a Flash document. Vari-
able width text blocks will automatically expand their width to accommodate
additional text. Fixed width text blocks, on the other hand, keep their width,
expanding their length and wrapping additional text to fit. The text contained in
text blocks can be formatted, edited, and moved. Text blocks themselves will
interact with other objects on the same layer, so beware of overlapping.

When creating and modifying text blocks, you’ll work with the Property Inspec-
tor, which displays character and paragraph formatting properties whenever the
Text tool or text is selected. The following is a list of text attributes that can be
changed with the Property Inspector:

• Font, color, and size

• Bold and italics

• Alignment and text direction

• Character adjustment

• Margins, using the Format button

• Text border

• Setting a hyperlink

Text Fields
You can also add text using text fields. Much more than a text block, a text field
offers interactive functionality. You can use text fields to request user input such
as names or passwords, or you can use them to display information that varies
from session to session, such as quiz scores. However, in order for interactivity to
be part of your movie, you must either use ActionScript, the Flash coding lan-
guage, to include the text as part of an action, or a Common Gateway Interface
(CGI) program, which accepts and returns data to your site. An example of when
you would use a CGI would be with an order form for merchandise on the Web.

TASK 4A-1:
Creating and Editing Text Blocks

1. Navigate to and open the jammin_banner.fla file.

2. First you will clear the bottle cap you created off the Stage, so that you have
room for to work with the text. Drag the bottle cap so that it is completely
off the Stage to the left.

ActionScript:
The coding language used in

Flash.

Common Gateway
Interface (CGI):

A program designed to
accept and return information

from a Web site.
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3. Next you will eliminate the outline on the “j” so that it better matches the
text you will add, and reposition it so it is centered on the Stage. Select and
delete the outline on the “j,” and reposition it is vertically centered on
the Stage.

4. Select the Text tool .

5. Click to the right of the “j” you created and type ammin’ juice. The text
is added to the Stage in a text block. The circle-shaped handle on the text
box indicates that this is an extending text block which will resize to accom-
modate the text which it contains.

6. Select the text.

7. The Property Inspector provides options for setting the font, type size, style,
and color of selected type, among other options. One option is to choose
between static, dynamic, and input text. Because the text you are entering
will simply appear in the movie, not add interactivity or information, you
will leave it at the default setting of static text. First you will format the
text. Choose Arial from the Font drop-down list.

8. Choose 40 from the Size drop-down list.

9. Choose the custom purple color from the Text Fill drop-down list.

10. Click on the Bold button.

11. You can reposition a text block the same way you reposition a simple object.
Select the Arrow tool.
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12. Select and drag the text block so that the top of the letters lines up with
the top of line of the “j.”

13. You’ve been working with a variable width text block. You also have the
option of working with a fixed width text block. This type of text block can
be useful for positioning text within a certain area of the Stage. Select the
Text tool, if necessary.

14. Drag on the Stage to draw a text block approximately two inches in
width. Notice that this fixed width text block has a square corner handle.

15. In the text block you just created, type ALL NATURAL ISLAND ELIXIRS.
The text wraps automatically.

16. Resizing a fixed width text block is easy. Drag the square corner handle to
the right until the text fits onto two lines.

17. You can also change a fixed width text block into a variable width block by
double-clicking on its corner handle. Double-click on the corner handle for
the fixed width text block. It changes to variable width.

Because you can’t see the
letters when you’re dragging

the text block, you can
position it approximately

where you want it and then
use the arrow keys on the

keyboard to position it more
precisely.
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18. You can also change the character and paragraph properties for the entire
text block, once it is selected with the Arrow tool. Select the Arrow tool.
The text block you just created is selected. Any changes you make in the
Property Inspector will now affect the whole text block.

19. Choose 15 from the Font Size drop-down list in the Property Inspector.

20. Finally, you can change the paragraph properties for a text block. You want
the tag line to be split under the words “Jammin’ Juice,” so that the “All
Natural” is in front of the hanging “j” in “Juice” and “Island Elixirs” is after
it. You will create a new text block and split the text between the existing
one and the new one. Select the Text tool.

21. Click anywhere on the Stage and type ALL NATURAL.

22. Double-click the first tag line text block you created, select, then delete
the words “ALL NATURAL” and the space before “ISLAND.”

23. You will set the paragraph alignment for each of these text blocks so that
they move toward the hanging “j” in “Juice.” Select the All Natural text
block and click the Right/Bottom Justify button in the Property
Inspector. Because your text block only has one line, the top and bottom
justify properties do not affect the text.

24. Select the Island Elixirs text block and click the Left/Top Justify button
in the Property Inspector.

25. Move the two text blocks below the “Jammin’ Juice” text box, so that
they are an equal distance from the hanging“j” in “Juice.”

Topic 4B
Converting Text into Shapes
Converting text into shapes by breaking it apart allows several possibilities. First,
by converting a character to a shape, you can then use the Arrow tool to change
the shape of the letter, in order to customize text. You can also add the flair of
fills or strokes to the text. Finally, converting text to shapes allows you to ani-
mate the characters individually, without having to type them as separate objects
to start with. However, as you convert shapes to text it is important to remember
that you cannot use the character and paragraph properties in the Property Inspec-
tor once they have been converted. Therefore it is important to get the text
properties just as you want them before you break them apart into shapes.

If the alignment buttons on
the Property Inspector are
hidden by the panel docking
area, drag the Property
Inspector window up, so that
it floats freely. To reposition
it below the Stage and work
area, choose one of the
panel sets from the Window
menu.

Lesson 4: Working with Text 57

DO
 N

O
T 

DU
PL

IC
AT

E

In
st

ru
ct

or
 E

di
tio

n



TASK 4B-1:
Breaking Apart Text

1. You will break apart the “ammin’ juice” text in the jammin_banner.fla file in
order to adjust some of the text, as well as animate it later. Select the
“ammin’ juice” text block and choose Modify→Break Apart. The blue
bounding box around all of the text is now several smaller boxes around
each letter, indicating that the larger text block has been broken down into
several smaller text blocks.

2. You want the text to be converted to shapes, not just broken down into
smaller text blocks. Choose Modify→Break Apart again. Each of the let-
ters is now selected as individual shapes.

3. Click anywhere on the empty Stage to deselect all the text.

4. The first change you will make to the text is to move the apostrophe closer
to the “n” at the end of “jammin’.” Click on the apostrophe.

5. Use the arrow keys on the keyboard to move the apostrophe closer to
the “n.”

6. You will now experiment with the changes that you can make to characters
once they have been converted to shapes. Select the Arrow tool and posi-
tion the cursor over the edge of the letter “e,” so that a corner appears
beside the cursor.

7. Click and drag the corner down and to the right. The letter is reshaped.

8. You can also change the fill of individual letters to a different solid or gradi-
ent fills once they are converted. Select the Paint Bucket tool and choose
dark blue from the Fill color drop-down list.

9. Click anywhere in the letter “e.” Only the fill for the letter “e” is blue.
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10. Finally, you can add a stroke color to characters, once they have been con-
verted to shape. Select the Ink Bottle tool and choose bright green from
the Fill color drop-down list.

11. Click on the outside edge of the “e.” A bright green stroke is added around
the outside edge of the letter.

12. Choose Edit→Undo to the letter “e” to its original color and shape.

13. Close the file and save any changes.

Summary
In this lesson you worked with text in Flash movies. You created variable
and fixed width text blocks. You also converted text to shapes, and then
modified their appearance in ways not possible with standard text.

Lesson Review
4A When would you use a fixed width text block as opposed to a variable

width one?

A fixed width text block can be useful when you wish to position text in a
limited area of the Stage.

4B Why would you want to convert text to shapes? What is a possible
drawback of this conversion?

Converting text to shapes allows you to modify the appearance of the text by
adding fills or outlines, modify the shape of the letters, and animate the
letters. One possible drawback is the fact that once you convert text to
shapes, you can no longer edit it as text, so there is no way to correct spell-
ing or change wording while keeping the same effects.
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Multiple Layers in a Movie

Overview
When you’re working with a large number of objects on a single layer, it
can become confusing to keep track of stacking order. Using multiple layers
can make shapes and objects easier to manage, and will allow you to create
a variety of effects without worrying about unwanted object interaction.

Objectives
In order to create Flash files with multiple layers, you will:

5A Create and manage multiple layers.

Multiple layers make working with numerous objects much more
manageable. You will create multiple layers, then perform a variety of
modifications on them.

5B Create a mask layer.

Mask layers allow you to create interesting effects in your Flash movies.
With this technique, you can create a layer which allows viewers to see
only selected portions of the layer below.

5C Align objects in a Flash document.

Flash provides several tools that make it easy to align objects in your
movies with precision.

Data Files
sm_island.jpg
juggling.fla

Lesson Time
1 hour

LESSON

5
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Topic 5A
Creating and Managing Multiple Layers
When you work with several objects on a single layer, things can get confusing.
Overlapping objects interact with each other and end up with new properties and
appearances. Also, when animating objects, it is easier to manage their individual
movements, when the object is on its own layer.

To create new layers, you work with the Timeline. Within the Timeline you can
add or delete layers, change the stacking order of layers, hide layers, lock layers,
and organize layers in folders. The Distribute to Layers command automatically
places any items you have selected onto different layers.

TASK 5A-1:
Creating and Deleting Layers

1. Navigate to and open the jammin_banner.fla file in the Flash MX Level
1 Data folder.

2. Everything you have added to this file is on a single layer. If you were to
move any of the letters in “Jammin’ Juice” or the bottle cap so that they
overlap, they would interact with one another. The overlapping portion of the
object lowest in the stacking order would be removed if the object above it
were later moved. Also, if you want to move the objects individually using
animation, it would be very difficult with all the letters on a single layer.
Therefore, you need to move each object on the Stage to its own layer. You
will start by adding a new layer for the “a” in“Jammin’ Juice.” Click the
Insert Layer button in the Timeline. A new layer, Layer 2, is added
and selected.

3. You will move the “a” to Layer 2. When you use the Arrow tool to select
the “a” on Layer 1, that layer is automatically selected in the Timeline.
Click on the “a” in“Jammin’ Juice.” The letter is selected.

4. Choose Edit→Cut. The letter “a” is cut from Layer 1.

5. Select Layer 2 in the Timeline.

6. Choose Edit→Paste in Place. The letter reappears on the Stage in the same
location, but is now on a different layer.
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7. Moving each of the letters and objects on Layer 1 to different layers can be
tedious and allow for frequent mistakes. Flash’s Distribute to Layers com-
mand quickly moves several objects to their own layers. Choose Edit→
Select All to select all of the items on the Stage and work area. All the
text and the bottle cap are selected.

8. Choose Modify→Distribute to Layers. In the Timeline, many layers are
created, each containing a different object from the Stage and work area.
Any text blocks that are distributed using this command are automatically
labeled with the text in the block. All the other objects are given numerical
layer names.

9. To better see each of the layers in the Timeline, you can expand the size of
the Timeline window by dragging its lower edge down. Position the cursor
over the lower edge of the Timeline until it changes to a Resize cursor

and drag down to show more layers.

10. There are some things to consider when using the Distribute to Layers com-
mand, however. Select the “j” in “Jammin’.” The layer with the “j” on it is
highlighted in the Timeline.

11. Select the dot above the “j.” A different layer is selected, indicating that
the dot was put on a separate layer from the main part of the “j.”

12. You will return the letters to one layer. Choose Edit→Undo until all the
letters are on one layer, as indicated in the Timeline.

13. With the Arrow tool, draw a selection marquee around the “j” and dot
in “jammin’.”

14. Choose Modify→Group. A blue bounding box appears around both, indi-
cating that they are grouped.

15. Select the “i” and its dot in “jammin’” and group them.

16. Select the “n” and the apostrophe after it in “jammin’” and group them.

17. Select the “j” and its dot in “juice” and group them.

18. Select the “i” and its dot in “juice” and group them.

19. Now that the pieces are grouped appropriately, you will redistribute them to
layers. Choose Edit→Select All to select all of the items on the Stage and
work area.

You may want to close the
Property Inspector, if it is
open, in order to better view
the Stage and the Timeline
together.

Zooming in may help select
only the letter and its dot.
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20. Choose Modify→Distribute to Layers. Each object is moved to a separate
layer.

21. When you select a layer in the Timeline, the contents of that layer are also
automatically selected. Click on several layers. The item on each layer is
selected on the Stage when you click on its layer.

22. Finally, you will delete Layer 1, because all the objects on it were distrib-
uted to other layers. Select Layer 1 in the Timeline.

23. Click on the Delete Layer icon in the Timeline. Layer 1 is deleted.

24. Select Layer 2 and delete it also.

Layer Organization
When you begin to work with a variety of layers, it can become difficult to
remember what objects are on each layer. To make things easier, you can rename
your layers to give them more descriptive names. Then, once your layers are
renamed, you can further organize your movie by grouping similar layers into
folders. Finally, when you position layers in different orders you affect the way
they appear on the Stage. Any objects in those layers in the higher positions in
the Timeline will appear on top of objects in any layers lower in the Timeline.

TASK 5A-2:
Organizing Layers

1. First you will rename each of the letter, text block, and bottle cap layers.
Click in the first J to select its layer, then choose Modify→Layer. The
Layer Properties dialog box displays.

2. To better identify the letters in “Jammin’ Juice,” you will add a numerical
indicator after any letters that are duplicated. Therefore, the layer for the first
“j” will be “J1” and the layer for the second will be “J2.” The other letters
you will need to add numerical indicators for will be the “m’s” and the
“i’s.” In the Name field, type J1

The layer name in the Timeline is now J1. Click OK.

The new layer numbers are
much higher than previously.

This is because Flash does
not use the numbers that

were used previously when
you distributed the objects to

separate layers. You will
change the layer numbers to

names in the next activity.
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3. You can also rename a layer by double-clicking on the name displayed in
the Timeline. First you must determine which letter is on a layer. Click on
Layer 22. One of the letters on the Stage is selected.

4. Double-click on Layer 22. The name Layer 22 is selected and the insertion
point is blinking after it.

5. Type the letter name and press [Enter]. The layer name in the Timeline is
now renamed.

6. You will rename the rest of the layers. Use capitals for the letter names so
they are easier to identify and name the bottle cap layer “bottle cap.” The
two text block layers were already named when you distributed objects to
layers, so you will leave them as they are. When you select a layer and the
Arrow tool is activated, its contents are selected, making it easy to identify
them as you rename the layer. Select any layer, double-click on the layer
name, and rename it to reflect its contents.

7. Rename the rest of the letter and bottle cap layers.

8. Once your layers are named, you want to further organize them into folders.
You will place each of the letters in one folder named for the word they
spell. Select the layer at the top of the list in the Timeline.

9. Click the Insert Layer Folder icon in the Timeline. A folder is
added above the layer.

10. Layer folders are renamed in the same way as layers. Name the folder
Jammin’.

11. To move layers in the Timeline, you simply drag them to the position you
want them to be in. Drag the J1 layer over the Jammin’ folder layer until
the folder selected and release the mouse. The J1 layer is moved into the
Jammin’ folder.

12. Repeat these steps to put the other letter layers for the word “jammin’”
in order in the folder layer.
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13. Once you have moved your layers into a folder, you can collapse and
expand the folder to manage the space on your screen better. Collapse the
Jammin’ folder layer.

14. Select the layer under the Jammin’ folder layer.

15. Add a folder layer and name it Juice.

16. To select several layers at once, you can click on one and then press the
[Shift] key while clicking another. All the files in between the two will be
selected. Click on the C layer.

17. Hold down the [Shift] key and click on the E layer. All the layers in
between are selected.

18. Drag the layers into the “Juice” folder layer.

19. Select and drag any other folders for the word“juice” into the folder
and put them in order.

20. Collapse the Juice folder layer.

21. Finally, you want to change the order for the bottle cap in the Timeline.
Drag the bottle cap object onto the Stage, over the word “jammin’.”
Because it is lower in the stacking order, the bottle cap appears behind the
text.

22. You want the bottle cap to appear over the words when it is animated, so
you will move that layer to the top of the Timeline. Drag the bottle cap
layer above the “Jammin’” folder layer in the Timeline. The bottle cap is
now over the text.

23. Drag the bottle cap off the Stage again.

24. Make sure the layers for ISLAND ELIXIRS and ALL NATURAL are
below the Juice folder.

To select layers that aren’t
next to each other at the

same time, hold down the
[Ctrl] key as you click on

them.
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Locking and Unlocking Layers
When you lock a layer, you prevent it from being unintentionally altered. When
working with overlapping objects on multiple layers, this feature can be espe-
cially helpful. If you later wish to edit a locked layer, you’ll need first to unlock
it. As you can see in Figure 5-1, next to each layer in the Timeline there are three
columns. The first column controls whether the layer is visible. The second col-
umn determines whether or not a layer is locked, and the third layer provides
options for a layer’s outline color. You will use hidden layers and outline colors
shortly. For now, you’ll lock and unlock layers.

Figure 5-1: The lock/unlock feature controls whether a layer is editable or not.

TASK 5A-3:
Locking and Unlocking Layers

1. When working with text, it is often difficult to select individual letters with-
out having to zoom in. Draw a selection marquee around the “i” in
“jammin’,” which includes part of the “m” to the left of it. The “i” is
selected, but so is the part of the “m” that was included in the selection
marquee.

2. Click anywhere on the Stage that is empty to deselect the letters.

3. When you lock a layer, you ensure that the objects on it cannot be altered or
moved. When several layers are in one folder, clicking on the dot in the
Lock column for that folder will lock all of the files in that folder. Click on
the dot in the Lock column of the Jammin’ folder layer.

4. Expand the Jammin’ folder layer. All of the layers in the folder are
locked.
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5. In order to make changes to a layer, it must be unlocked. Click the lock
icon in the Lock column of the I1 layer. The layer is unlocked, however
the rest of the layers in the folder remain locked.

6. Again, draw a selection marquee around the “i” in “jammin’,” which
includes part of the “m” to the left of it. Only the letter “i” is selected.

7. Finally, to easily lock or unlock all the layers, you can click on the lock icon
at the top of the Lock column. Click on the lock icon at the top of the
Lock column. All the layers are locked, and the “i” is no longer selected in
“jammin’,” because it can no longer be changed or altered.

8. Click on the lock icon at the top of the Lock column again. All the layers
are unlocked.

Hidden Layers and Outlines
When you’re editing objects on a layer in a multi-layered movie, it can some-
times be helpful to hide other layers. This helps you to focus your editing efforts
on the layer at hand, without the distraction of objects on other layers, especially
if they are overlapping. Another tool useful when working with complex draw-
ings is the ability to view objects as outlines. This option can be especially
helpful when you are working with a complex multi-layer movie, and you wish
to quickly determine which objects belong to which layer. By assigning a differ-
ent outline color to each layer, you have a visual cue for making this distinction.

In the Timeline, as shown in Figure 5-2, the first column next to the layer name
has an eye icon at the top. This column, the Show/Hide column, determines
whether a layer is hidden or visible. Clicking on the eye will show or hide all of
the layers in the open movie. On the other side of the Lock/Unlock column the
Show Layer as Outline column has a box indicating the color of the outline for
that layer.

Figure 5-2: The Show/Hide and Show Layer as Outline features determine if and how a
layer appears.
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TASK 5A-4:
Hiding Layers and Displaying Outlines

1. You will work with different layers to see how you can hide a layer. Click
on the dot in the Show/Hide Layers column next to the All Natural
layer. The text block on that layer no longer appears on the Stage and a red
X appears in the Show/Hide column for this layer, indicating that it is
hidden.

2. Just as you can lock all the layers within a folder, you can also hide all the
layers in the folder by clicking on the dot in the Show/Hide column beside
the folder layer. Click on the dot in the Show/Hide Layers column next to
the Jammin’ folder layer. The word“jammin’” no longer appears on the
Stage and a red X appears in the Show/Hide column for all the layers in the
folder.

3. Finally, you can hide all the layers in the movie by clicking on the eye icon
at the top of the Show/Hide Layers column. This is useful when you have a
large number of layers, but only want to view one or two. You can quickly
hide all the layers and unhide the ones you want to work with. Click the
eye icon at the top of the Show/Hide Layers column. No objects appear
on the Stage and a red X appears in the Show/Hide column for all the layers
in the movie.

4. Click on the eye icon at the top of the Show/Hide Layers column again,
to show all the objects in the movie.

5. Showing the objects as outlines works just as hiding or locking layers. You
can choose individual layers, select all the layers in a folder, or select all the
objects in the movie to be shown with outlines. Click on the square in the
Show Layer as Outline column next to the Jammin’ folder layer. Each of
the letters for the word “jammin’” is outlined in a different color, indicating
what layer they are on.

6. You also have the option to change a layer’s outline color. Currently the
layer color for the Island Elixirs layer is light blue. To change this you
access the Layer Properties dialog box. Select the Island Elixirs layer and
choose Modify→Layer. The Layer Properties dialog box appears.

7. Choose a dark blue color from the Outline Color drop-down list and
click OK. The outline color box changes in the Show Layer as Outline
column.
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8. Click on the square in the Show Layer as Outline next to the Island
Text layer. The text in the text block for that layer is shown in the dark blue
color.

9. Click the Show Layer as Outline squares for the Jammin’ folder layer
and the Island Elixirs layer.

10. Choose File→Save.

Topic 5B
Mask Layers
Layers can be useful for organizing your movies, but they can also help you to
add interesting effects to your movies. For example, with a mask layer, you can
designate which areas of a particular layer are visible. Similar to a stencil, the
mask layer hides portions of the layer directly below, known as the masked layer.
In order to create masking effects, layers must be linked together.

TASK 5B-1:
Creating a Mask Layer

1. You will use a mask layer to create a pattern under the first “j” in the
Jammin’ Juice banner ad. Expand the Jammin’ folder layer and select the
J1 layer.

2. You need to add a second layer for the mask layer. Click the Insert Layer
button in the Timeline. A layer is added above the J1 layer.

3. Rename the layer “Island Mask.”

4. Since the J1 layer will be the mask layer, it must be above the Island Mask
layer in the stacking order. Drag the Island Mask layer below the J1
layer.

5. You will use a JPEG document as the graphic that will appear under the J1
mask layer. First you need to import the graphic onto the Island Mask layer.
Select the Island Mask layer.

6. Choose File→Import.

7. Navigate to and open the sm_island.jpg file in the Flash MX Level 1
Data folder. An island scene is imported onto the Island Mask layer.
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8. Position the island image so that it is covered by the “j” in “jammin’.”

9. You are ready to turn the J1 layer into a mask layer. Double-click on the
Layer Name icon to the left of the J1 layer name. The Layer Properties
dialog box appears.

10. Click the Mask radio button in the Type list and click OK. The icon
beside the layer name has changed, indicating that it is a mask layer.

11. You now need to designate the Island Mask layer as the masked layer.
Double-click on the Island Mask Layer Name icon. The Layer Properties
dialog box appears.

12. Click the Masked radio button in the Type list and click OK. The Island
Mask layer now appears indented below the J1 layer in the Timeline, the
Layer Name icon indicates that it is now a masked layer, and a dotted line
between the two layers indicates that the two are connected.

13. To see the effects of the mask layer, you will need to lock both the mask
layer and the masked layer. Click on the Lock icon at the top of the lock
column to lock all layers in this document. The mask layer effect displays.

14. Close the file and save the changes.
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Topic 5C
Aligning Objects
Trying to align objects in your Flash movies by eye can be both frustrating and
imprecise. Luckily, Flash provides tools that help with this dilemma. The Align
panel provides several options for positioning objects on the Stage. You can align
objects horizontally or vertically along their right edge, center, or left edge. You
can also use the Align panel to distribute objects so that they are evenly spaced,
or to resize objects to share the same dimensions.

TASK 5C-1:
Aligning Objects

1. Navigate to and open the juggling.fla file. This document has five layers.
The lowest layer is Jimmy, a bitmap graphic. The other layers, Orange,
Lime, Apple, and Pineapple are all graphic objects that were created in
Flash.

2. You’ll use the Align panel to position the objects in a more pleasing manner.
Select the Pineapple layer, hold down the [Shift] key, and click on the
Orange layer. This selects the four fruit layers, and the fruit objects on the
Stage are all selected as well.

3. Expand the Align panel, if necessary.

4. Click on the Align Top Edge button . All of the fruit is lined up along
the top edge of the orange, since this object was the highest selected object.

5. Next, you’ll even up the fruit’s spacing horizontally. Verify that all of the
fruit objects are selected.
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6. Click on the Space Evenly Horizontally button . The fruit objects
are spaced evenly horizontally, while retaining their vertical alignment.

7. When Flash determined the horizontal spacing for the selected objects, it
spaced the two middle objects evenly relative to the objects on either end.
Since the objects are all close together, this has caused some overlapping. To
correct this, you’ll need to reposition the two outer objects. Select the Pine-
apple layer.

8. Drag the pineapple to the left about an inch.

9. Select the Apple layer, and then drag the apple to the right about an
inch.

10. Next, you’ll re-apply the horizontal spacing, but first you must re-select the
fruit layers. Select the Pineapple layer, hold down the [Shift] key, select
the Orange layer.

11. Click on the Space Evenly Horizontally button again. The lime and
orange are spaced evenly and none of the fruit objects overlap.

12. Close the file and save the changes.

Summary
In this lesson, you worked with Flash movies that contained multiple layers.
You created multiple-layer movies, and then edited and manipulated them.
You created a visual effect using mask layers. You also worked with the
Align panel to quickly arrange objects on multiple layers.
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Lesson Review
5A When and why might you want to add layers to a Flash document?

Layers are useful when you are working with a Flash document that has
multiple objects in it. Layers allow you to better manage the objects in your
document. You can change the stacking order, lock layers to prevent making
unintended changes, hide layers to make editing easier, and use outlines to
see object placement without distracting details.

5B What are the basic steps for creating a mask layer?

Create two layers and place the appropriate graphics on each, put them in
the proper stacking order, use the Layer Properties dialog box to establish
one layer as the mask layer and the other as the stacking layer, then, lock
both layers to view the mask.

5C What options for aligning objects are available in the Align panel?

With the Align panel, you can align objects horizontally or vertically along
their right edge, center, or left edge. You can also distribute objects so that
they are evenly spaced, or resize objects to share the same dimensions.
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Creating Animation

Overview
Since Flash animation can be found all over the Web, it’s often the primary
thing that comes to mind when the program is mentioned. Flash can be used
to create three basic types of animation: frame-by frame, shape tweening,
and motion tweening. In this lesson, you will work with all three types of
animation. You will also see how adding a guide layer can improve the look
of motion-tweened animation.

Objectives
In order to animate objects in Flash, you will:

6A Create a frame-by-frame animation.

Flash’s frame-by-frame animation is closest to traditional animation in
that it is composed of several frames designed to simulate motion.

6B Create a shape-tweened animation.

Shape-tweened animations allow you to create the effect of one shape
transforming into another.

6C Create a motion-tweened animation.

Motion tweening allows you to give the appearance of motion to objects
in your Flash movies.

6D Create a guide layer.

When creating a motion tween along a complicated path, creating a guide
layer can save development time.

6E Animate a mask layer.

Utilizing motion-tweened animation, you can create dynamic effects using
two layers, with one as a mask which is animated. This allows you to
control and vary what the fill of the moving objects will be.

Data Files
drinking1.gif
drinking2.gif
drinking3.gif
drinking4.gif
drinking5.gif
drinking6.gif
drinking7.gif

Lesson Time
1 hour, 15 minutes

LESSON

6
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Topic 6A
Frame-by-Frame Animation
Traditional animation uses a series of images in which slight changes from one
image to the next simulate action. Frame-by-frame animation in Flash operates
under the same premise. Using a series of frames in which action is simulated by
slight changes from frame to frame, Flash movies can give the appearance of
motion.

In Flash animation, the frames in which you define changes in your animation are
declared as keyframes. For frame-by-frame animations, each frame becomes a
keyframe, since there is a slight difference between each frame. In the Timeline,
keyframes are noted by circles.

TASK 6A-1:
Creating a Frame-by-Frame Animation

1. Choose File→New.

2. You’ll be working with some existing GIF files, so you’ll need to import
them. These files were designed to create an animation, so each file has a
slight difference from the previous file. When imported into Flash, they will
create a movie which simulates motion. Choose File→Import.

3. Navigate to and select the file Drinking1.gif, then click Open. A dialog
box appears, noting that the file appears to be part of a sequence and asking
whether you want to import all of the images in the sequence. Flash recog-
nizes a potential sequence of files when a group of files is named in
numerical order: in this case Drinking1, Drinking2, etc.

4. Click Yes to import the entire sequence.

5. Flash imports the sequence of files and places them in consecutive frames.
To preview the animation, press the [Enter] key. You have created a
simple frame-by-frame animation.

6. Close the file and save it as frameanimation.fla in the Flash MX Level 1
Data folder.

keyframe:
A frame in which a change in

animation is defined.
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Topic 6B
Shape-Tweened Animation
Flash makes it easy to create the effect of one object transforming or morphing
into another with the animation process called tweening. Tweening is a type of
animation in which the beginning and end states are defined using the Stage and
Timeline, and all states in between are calculated by Flash. You can also use
tweening to create animations that change the color, size, location, or transpar-
ency of the selected objects. With shape tweening, you could create the effect of
transforming an image of a frog into an image of a handsome prince by simply
creating keyframes containing the starting and ending images, and then instruct-
ing Flash to create a shape tween. Shape tweening is only available for simple
shapes in Flash; you cannot create shape teens with symbols, groups, or bitmap
images. To create a shape tween, you will use the Property Inspector.

TASK 6B-1:
Creating a Shape-Tweened Animation

1. You’ll create a morphing effect in which an orange morphs into a lime. First,
you’ll need to copy the fruit shapes. Open the fruit.fla in the Flash MX
Level 1 Data folder.

2. Use the Arrow tool to draw a selection marquee around the orange
shape.

3. Choose Edit→Copy.

4. Now you’ll need to create a new document in which to paste your copy of
the orange shape. Choose File→New.

5. Choose Edit→Paste to place the orange on the Stage.

6. Currently, your Flash document has no frames. In order to create an anima-
tion, you must add frames. Click on frame 25 in the Timeline and choose
Insert→Blank Keyframe. Flash adds a keyframe in the Timeline, and
inserts frames between frame 1 and 25.

7. You’ll need to return to the Fruit document to copy the lime. Choose
Window→fruit.fla.

8. Select and copy the lime shape.

tweening:
Animation in which the
beginning and end states are
defined using the Stage and
Timeline, and all states in
between are calculated by
Flash.
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9. To return to your movie, choose Window→Untitled-1.

10. Choose Edit→Paste. The lime is pasted onto frame 25.

11. To preview your animation, click on frame 1 in the Timeline, then press
[Enter]. As the animation plays, you’ll see that the orange appears in frames
1 through 24, and the lime is only in frame 25.

12. Reselect Frame 1 in the Timeline.

13. You’re ready to create a shape tween between the orange and the lime.
Choose Shape from the Tween drop-down list.

14. Flash creates the shape tween. This is indicated in the Timeline by an arrow
and shading between frames 1 and 25.

Choose Control→Play to view the animation. The orange morphs into the
lime.

15. Close the file and save it as orangetween.fla in the Flash MX Level 1
Data folder.

Topic 6C
Motion-Tweened Animation
With motion tweening, you can easily create motion effects for the objects in
your Flash movies. Kites flying, balls bouncing, rocks rolling—all of these ani-
mations can be made simple and easily with motion tweening. Flash can tween
object position, size, rotation, skew, and color. When you create a motion tween,
you’ll first use the Insert menu to create a motion tween. Flash will position the
object to simulate motion in the frames between your keyframes.

Depending on the number of
new movies you’ve opened,
your movie may be named

differently.
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TASK 6C-1:
Creating Motion-Tweened Animation

1. Navigate to and open the jammin_banner.fla file in the Flash MX Level
1 Data folder.

2. You will hide the masked image for the “j.” Click on the dot in the Show/
Hide column of the Island Mask layer. Unlock all layers.

3. First, you will position all the objects where you want them at the beginning
of the animation. The first “j” will remain static on the Stage, the rest of the
“jammin’ juice” text will drop in from above, the two text blocks will
increase in size, and the bottle cap will “roll” in from the left of the Stage.
Use the lasso tool to select all the “jammin’ juice” text, except for the
first “j.”

4. Drag the letters above the Stage.

5. Select the bottle cap and drag it to the left of the Stage, if necessary.

6. Next you need to decide how long you want the movie to be. For example,
if you are using the default frame rate of 12 frames per second (fps), a five
second movie would then be 60 frames. The animation in this banner add
will be approximately 3 seconds, so you will need 36 frames. Click on
frame 36 of the bottle cap layer in the Timeline.

7. Choose Insert→Frame. Frames 1 through 36 are shaded to indicate that
these frames have been added. Now, the contents of the bottle cap layer will
display throughout the movie.

8. Click on any frame of the bottle cap layer.

9. Choose Insert→Create Motion Tween. Flash adds blue shading to the
frames in the bottle cap layer, indicating that a motion tween has been
created. The dotted line in the frames indicates that the tween is not
complete. Once the tween is finished, the dotted line will change to an
arrow.

10. To complete the motion tween, you will first need to move the playhead (the
red square currently located at frame 1) to the last frame of the movie. Drag
the playhead to frame 36.
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11. Drag the bottle cap object to the right of the Stage.

This creates the motion that the bottle cap will make and places it in its final
position. The dashed line in the Timeline has changed to an arrow, indicating
that the tween is complete.

12. You will preview your animation. Choose Control→Play. The bottle cap
moves across the Stage.

13. You can also make objects rotate as they move. Click on any frame for the
bottle cap layer. All the properties that can be changed in the tween are
listed in the Property Inspector.

14. Choose CW (clockwise) from the Rotate drop-down list.

15. Type 6 in the Times field and press [Enter].

16. Choose Control→Play. The bottle cap rolls onto the Stage.

17. Next you will animate the rest of the elements on the Stage. To quickly add
frames to each layer, you can select a frame on one layer, press the [Shift]
key, and select that frame on another layer, and Flash will select all those
layers. Then, when you insert a frame, all the layers will have frames added.
Expand the Jammin’ and Juice folder layers.

18. Click in frame 36 of the J1 layer, hold down the [Shift] key, and click in
frame 36 of the All Natural layer. Frame 36 in all the layers is selected.
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19. Choose Insert→Frame. Frames from 1 through 36 are added to all the
layers.

20. Just as you inserted frames on several layers, you can create a motion tween
for several layers at once. Click in frame 1 of the A layer, hold down the
[Shift] key, and click in frame 1 of the E layer. The first frame for each of
the letter layers is selected.

21. Choose Insert→Create Motion Tween. Dotted lines are added to each of
the letter layers.

22. Move the playhead to frame 36 and click on frame 36 of the A layer.

23. You will complete the tweens for each of the letters, moving them down to
their original positions on the Stage. Drag the letter A to its original posi-
tion on the Stage.

24. Repeat these steps for the other letters to move them to the Stage at
frame 36.
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25. To align the letters once they are in their final position, you can use the
Align panel. With the playhead at frame 36, use the Arrow tool to draw
a selection marquee around the text you just moved, except the second
J. All the letters are selected except the second “j.”

26. Expand the Align panel, if necessary.

27. Click the Align Bottom Edge button.

28. You don’t want all the letters to move at once, but to stagger themselves as
they fall, so you will change the start and end times for each of the letters.
You can easily change the duration of a tween by holding down the [Ctrl]
key and moving the beginning or the ending keyframes of the tween. Posi-
tion the cursor over the frame 1 of the A layer and press the [Ctrl] key.
The cursor changes to a two-sided arrow.

29. Drag the keyframe over to frame 2 of the movie. You have changed the
start of the tween.

30. Position the cursor over frame 36 of the A layer, press the [Ctrl] key,
and drag it to frame 8. The duration of the tween is now only 6 frames.

31. Move the playhead to frame 1 and choose Control→Play. The letter “a”
moves down more quickly than the others, however it disappears once it is
down.

32. You will add a keyframe in frame 36 of the movie, so the “a” remains on
the Stage. Click in frame 36 of the A layer and choose Insert→Frame.
The frames between 8 and 36 are shaded in, and a dotted line indicates that
an incomplete motion tween is present.

33. You will remove the tween from the second part of the Timeline for the A
layer. Click on frame 9 of the A layer.

34. In the Property Inspector, choose None from the Tween type drop-down
list. The frames between 9 and 36 of the “A” layer are shaded grey.

The second “j” should not be
selected, because of the

hanging part. You will align
the letters to the bottom, and

that part would cause the
rest to be too low.
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35. You will change the duration of the tweens for the other letters. Each tween
should start 1 frame after the previous letter started, and end one frame later
than the previous letter ended. Repeat these steps to stagger the rest of the
letters by changing the duration of their tween, and then adding frames
so they remain on the Stage.

36. Finally, you will change the scale of the two text blocks that are on the
Stage, so that they appear to be zooming in. First you will move them down
slightly, so they have room to move up as they zoom in. Select frame 1 in
both text block layers.

37. Drag both down approximately half an inch on the Stage.

38. With frame 1 still selected in both layers and create a motion tween.

39. Move the playhead to frame 36 and drag the text blocks to their original
position. Tweens are indicated by a solid arrow in the Timeline for each
layer.

40. You will use the Transform panel to scale the text blocks as the movie plays.
Expand the Transform panel, if necessary.

41. Click in the first keyframe of the All Natural layer.

42. Type 5 in the Width field on the Transform panel and press [Enter]. The
text block appears to disappear on the Stage.

43. Repeat these steps to change the size of the second text block.

44. You are ready to view the finished movie. Press [Enter]. All of the motion
tweens you added to the movie appear as the movie plays.

45. Close the file and save the changes.

To make room on the screen,
you may want to collapse the
two folder layers in the
Timeline.
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Topic 6D
Guide Layers
The simplest motion tweens move objects from point to point along a straight
path. You can create more varied paths by adding keyframes to redirect the
motion over the course of the movie. However, this can be time-consuming work.
Creating a guide layer makes it much easier to create an intricate path along
which your objects can travel.

A guide layer contains a path along which a motion-tweened object will travel.
The path can be drawn with any of the Flash drawing tools. The guide layer is
linked with the layer on which the animation resides. Guide layers are invisible to
the end user.

TASK 6D-1:
Creating a Guide Layer

1. Open the ocean.fla file in the Flash MX Level 1 Data folder. Flash opens
a document with four layers, a bottle layer, a sky layer, and two ocean
layers.

2. Select frame 25 for all four layers and insert a frame. All the objects on
these layers will now last for 25 frames.

3. Create a motion tween in frame 1 of the bottle layer, if necessary.

4. Move the playhead to frame 25 and drag the bottle to the right side of
the Stage.

5. You are now ready to create a guide layer which will make the bottle appear
to bob in the ocean. Click on the Add Motion Guide button in the
Timeline. Flash creates a guide layer above the bottle layer.

6. Click on frame 1 in the guide layer.

7. You will draw the motion guide for the bottle to follow. Select the Pencil
tool and choose the Smooth Pencil mode from the options section.

You may need to zoom out
to view the whole Stage.
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8. Draw a wavy line from the bottle on the left to the right of the Stage.

9. Click on the dot in the Show/Hide column of the Guide:bottle layer to
hide the motion guide.

10. Finally, you want to see what the animation will look like with the bottle
maintaining its original orientation. Click on frame 1 of the bottle layer
and uncheck the Orient to Path checkbox in the Property Inspector, if
necessary.

11. You can now preview your animation. Press [Enter].

Path Orientation
When working with complicated paths that twist and change direction, you can
improve your animation effects by orienting an object to its path. When you use
this option, the object will re-orient to follow the direction of the path.

TASK 6D-2:
Orienting to a Path

1. You will orient the bottle to its path. Click on frame 1 of the bottle layer.

2. Check the Orient To Path checkbox.

3. You are ready to preview the movie. Press [Enter]. By orienting the bottle
to its path, it appears to bob in the ocean.

Editing a Motion Guide Path
You are free to edit a path once you have established it, but this may create some
problems with your animation. For example, greatly altering a guide path may
result in the object becoming disconnected from its path. Becoming familiar with
editing techniques will help your animations run smoothly.
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TASK 6D-3:
Editing a Motion Guide Path

1. As you played the animation in the last activity, you noticed the bottle
bobbed very high in the waves. You will move the motion guide down on
the Stage. Select the Guide:bottle layer. Although it is selected, the path
does not appear because the Show/Hide column is checked for it.

2. Click on the red X in the Show/Hide column of the Guide:bottle layer.
The path appears on the screen.

3. Click on the Guide:bottle layer to select the whole path.

4. Drag the path down one and a half inches.

5. Play the animation. The bottle moves in a straight line because the motion
guide was moved too far away from it.

6. Click on the Guide:bottle layer to select the path.

7. Drag it so that it is just below the surface of the waves and near the
beginning of the bottle.

8. Play the animation. The bottle again appears to bob in the ocean, but not as
high.

9. Close the document and save the changes.

Topic 6E
Mask Animations
In combining two features of Flash, mask layers and motion tweening, many
interesting effects can be created. Because either layer can be animated when you
have a mask and a masked layer, you have a lot of freedom to create variety in
your movies.

You may want to hide the
ocean layers to view the

motion guide more clearly.

Hide and show the Ocean
layers as necessary.
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TASK 6E-1:
Animating a Mask Layer

1. You will use an animated mask to create the appearance of binoculars look-
ing at an island. Choose File→New.

2. Set the movie size to 700 x 300, using the Property Inspector.

3. First you will add and name a second layer to the movie. Click the Insert
Layer button in the Timeline.

4. Name layer 1 island and layer 2 binoculars.

5. You will create the binocular shape. Select the binoculars layer.

6. Draw a circle with no outline and a black fill, approximately 2 inches in
diameter.

7. Duplicate the circle.

8. Drag the second circle over the first to create a shape that looks like
lenses and place the binoculars in the middle left of the Stage.

9. Next you will set the binoculars layer as the mask layer. Double-click on
the Layer Name icon for the binoculars layer. The Layer Properties dialog
box appears.

10. Click the Mask Layer radio button and click OK.

11. You are ready to animate the mask layer. Click on frame 50 of the binocu-
lar layer, insert a frame, and insert a motion tween.

12. Click on frame 50 of the island layer and insert a frame.

13. Click on frame 50 and drag the binoculars to the bottom left side of the
Stage.

14. To create a change of direction in a masked motion tween, you simply click
on frames within the original motion tween and move the objects on the
Stage. You will have the binoculars move clockwise around the Stage. Click
on frame 10 and drag the binoculars to the top left of the Stage.

15. Click on frame 20 and drag the binoculars to the middle of the Stage.

16. Click on frame 30 and drag the binoculars to the top right of the Stage.
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17. Click on frame 40 and drag the binoculars to the middle right of the
Stage. You are done setting the animation for the binoculars.

18. Now all you have to do is place an image on your masked layer and your
mask animation is set. Select frame 1 in the Island layer.

19. Choose File→Import.

20. Open the lg_island.jpg file in the Flash MX Level 1 Data folder. The
island image appears on the Stage.

21. Enlarge and center the image so that it covers the Stage.

22. Double-click on the Layer Name icon for the Island layer. The Layer
Properties dialog box appears. Click the Masked radio button and click
OK.

23. Lock both layers so the mask effect appears.

24. One last thing you need to do to make your binoculars animation effective is
change the background of the movie. Click anywhere on the Stage to dese-
lect any objects and choose black from the Background color drop-down
list in the Property Inspector.

25. Press [Enter] to view the animation.

26. Save the file as binoculars.fla.

Summary
In this lesson, you worked with a variety of Flash animation tools. You cre-
ated frame-by-frame, shape-tweened, and motion-tweened animations. You
also added a motion guide layer to create a more complicated motion effect.
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Lesson Review
6A How is frame-by-frame animation similar to traditional animation?

Both forms of animation use a sequence of individual frames in which slight
differences between frames create simulated movement.

6B Which panel is used to create a shape tween?

The Property Inspector is used to create a shape tween.

6C What properties of an object can you control with a motion tween?

Location, size, rotation, skew, color, and transparency.

6D What are the basic steps involved in creating a guide layer?

Create a motion tween, insert a guide layer, and draw a path with one of the
drawing tools.

6E What are the steps for creating an animated mask effect?

Create mask and masked layer, then animate one of the layers using either
motion or shape tweening.
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Publishing Your Flash Movie

Overview
In order to distribute your Flash movie to an audience, you must publish it.
You will need to consider your distribution method and your audience as
you prepare a file for distribution.

Objectives
In order to prepare a Flash file for distribution, you will:

7A Select publishing settings.

Once you’ve finished a Flash movie, you will want to publish it so others
can see your work. Whether you plan to distribute your movie via the
Web or as a Macintosh or Windows projector file, you will need to pre-
pare your files accordingly.

7B View preview files and publish a Flash movie.

It’s a good idea to preview your Flash files before publishing them.
Flash’s Publish Preview option allows you to do just that.

Data Files
jammin_banner.fla

Lesson Time
30 minutes

LESSON

7
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Topic 7A
Selecting Your Publishing Settings
When you’re ready to publish a Flash file, you’ll need to specify which type of
file you wish to create for distribution. The Publish Settings dialog box contains
all of the publishing selections you’ll need to make.

The Formats tab of the Publish Settings dialog box asks you to specify the file
format you wish to create. Your first option, Flash (.swf) is selected by default,
and will create a Flash movie that is viewable through a Web browser with the
Flash Player plug-in. Also selected by default is HTML. This will create the
HTML document which is required to display a Flash movie in a Web browser.
Selecting GIF Image, JPEG Image, PNG Image, or QuickTime will create an
alternate file which will display in the selected format if the Flash Player is
unavailable. These files will also require an HTML file to display. The Windows
Projector and Macintosh Projector options will create standalone projector ver-
sions of your Flash movie.

The Use Default Names checkbox, which is checked by default, causes each file
created during the publishing process to use the name you’ve given your original
Flash file, followed by the file format extension. So, for example, if you were to
publish jammin_banner.fla as a Flash movie, the file would automatically be
named jammin_banner.swf. Also, any files created will be stored in the same
location where you saved your original .fla file.

Depending on the files you choose to create, additional tabs will appear in the
Publish Settings dialog box. These tabs provide settings pertinent to each particu-
lar file type. For example, the Flash tab provides choices for the order in which
the movie will load, the ability to run a file size report, an option to protect your
files from being imported and altered by others, as well as password, JPEG, and
audio settings.

TASK 7A-1:
Choosing Publish Settings

1. You’ll prepare the jammin_banner.fla file for publication on the Web. Navi-
gate to and open the jammin_banner.fla file in the Flash MX Level 1
Data folder.

2. To begin the publishing process, choose File→Publish Settings. The Publish
Settings dialog box appears.
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3. Verify that the Flash and HTML file types are selected, and that the Use
Default Names checkbox is checked.

4. Now you’re ready to specify settings for each of the files you’ll create.
Select the Flash tab.

5. Your first option in the Flash tab is to select the version you want the movie
to be published in. Depending on the level of your audience, you may want
to publish the file in an earlier version, so it can be seen be viewers with
earlier versions of the plug-in. For the purposes of this course, you will
accept the default option of Flash Player 6. The next option is to select the
order in which the movie will load over the Internet. You’ll accept the
default option, Bottom up, which will load the movie from the bottom layer
up. Next you have several options to choose from. Check the Protect From
Import checkbox. This option will prevent viewers from importing your file
into Flash and making changes to it. You will accept the rest of the default
settings for the Flash tab.

6. Select the HTML tab.
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7. The settings you choose in the HTML tab will govern the HTML file that
Flash generates in order to display your Flash movie and to control its
appearance. Choose Flash Only from the Template drop-down list. This
template plays the movie if the correct plug-in is present.

8. The HTML tab provides several other settings which can be modified. You
can set the dimensions of your movie to match the movie or establish them
in pixels or percentages. You also have the option to establish the behavior
of your movie — whether it will play on a continuous loop or if it will be
paused at its start, whether you’ll include a right-click shortcut menu, and
whether you wish to use an anti-aliased font for fonts not installed on the
viewers machine. You will leave the Dimensions setting at the default setting
of Match Movie. You do not want any of the Playback options at this time.
Uncheck the Display Menu checkbox, if necessary. You’ll accept the
default settings for the remaining options in the HTML tab.

9. Uncheck the Loop checkbox.

10. Click OK to close the Publish Settings dialog box and save your
selections.

Topic 7B
Previewing and Publishing Files
Once you’ve prepared your files for publishing, there are still two more steps you
must take before your movie is ready for distribution. First, you should take
advantage of the option to preview your file to make certain everything appears
as it should. Second, you must actually publish your file.

Just to be on the safe side, it’s a good idea to preview the result of your settings
before you actually publish your movie. Using the Publish Preview option allows
you to see the files as they will appear once published. If any editing is required,
you can quickly access the Publish Settings dialog box and make your changes.
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Once you’ve established that your publish settings are correct, you can proceed
with publishing your file. Remember that the finished files will all be created in
the same file in which the original Flash document resides. When you actually
move the HTML file and any other files to your Web server, be sure to keep them
in the same folder. Otherwise, you’ll need to go into the HTML document and
edit the references to these files.

TASK 7B-1:
Previewing and Publishing Your Files

1. Choose File→Publish Preview→Default-(HTML). Flash opens a browser
window, displaying your movie on an HTML page.

2. Close the preview window.

3. You are ready to publish your file. Choose File→Publish.

4. To view your published file, you’ll need to launch your Web browser.
Launch Internet Explorer or Netscape Navigator.

5. Locate and open the jammin_banner.html file. The finished, published
page appears in your browser window.

6. Close the browser window.

7. Exit Flash and save the changes to the jammin_banner.fla file.

Summary
In this lesson, you prepared a Flash movie for publishing to the Web. Then
you used the Publish Preview command to preview the files you had
prepared. Finally, you published the files and viewed them in a Web
browser.

Lesson Review
7A At the minimum, which files must be created in order to publish a Flash

file to the Web?

A Flash .swf file and an HTML file, which will control the way the Flash
movie is displayed on the page.

7B Why should you preview your files before publishing them?

Previewing your files allows you to see if any editing is required before you
actually publish the files.
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When uploading your published files to a Web server, why should you
keep them all in the original folder?

If published files are moved from their original folder, you will need to edit
the HTML document to indicate the new file structure.
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ActionScript
The coding language used in Flash.

anchor points
Locations on a vector line or curve which
determine the length and direction of the
line.

bitmap
A graphic image defined by grids com-
posed of pixels; raster graphic.

Common Gateway Interface (CGI)
A program designed to accept and return
information from a Web site.

frame
A movie segment composed of an indi-
vidual image.

gradient
Bands of color that blend into each other.
In Flash, gradients can blend up to eight
colors in linear or concentric patterns.

hexadecimal value
A unique six-digit code that is assigned to
a specific color value. Used by most Web
sites and HTML pages.

HSB value
Color that is determined by hue, saturation,
and brightness settings.

keyframe
A frame in which a change in animation is
defined.

layer
An organizational element that enables you
to stack images on top of one another.

pixels
Picture elements. Small squares which are
arranged on a grid to create raster graphics.

raster graphic
A graphic image defined by grids com-
posed of pixels.

registration point
The center point of an object.

RGB value
Color that is determined by the levels of
red, green, and blue that compose it.

selection marquee
A rectangular area, created with the Arrow
tool, which selects the objects within its
borders.

stacking order
The order in which items appear, based on
the order they were placed on the Stage.
Objects placed on the Stage later will be
higher in the stacking order and will
obscure objects already on the Stage.

tangent handle
The part of a vector curve which can be
adjusted to determine the slope and the
depth of the curve.

tweening
Animation in which the beginning and end
states are defined using the Stage and
Timeline, and all states in between are cal-
culated by Flash.

vector graphic
A graphic image defined by mathematical
equations.
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A
aligning objects, 72-73

animation

animating mask layers, 86-88

frame-by-frame, 76

motion-tweened, 78-83

shape-tweened, 77-78

Arrow tool, 32-34

B
Brush tool, 17-19

C
color

custom color swatches, 25

custom gradients, 26-28

hexadecimal, 25

HSB, 25

RGB, 25

Color Mixer panel, 25

D
drawing

Brush tool, 17-19

Eraser tool, 19-20

Eyedropper tool, 23-24

Ink Bottle tool, 23-24

Paint Bucket tool, 20-23

Pen tool, 11-15

Pencil tool, 9-11

E
Eraser tool, 19-20

Eyedropper tool, 23-24

F
fill properties, 15-16

Flash environment, 3-4

frame-by-frame animation, 76

frames, 3-4

G
gradients, 20-23

custom gradients, 26-28

graphics

importing, 48-51

grouping objects, 47-48

guide layers, 84-85

H
hexadecimal color, 25

HSB color, 25

I
importing graphics, 48-51

Ink Bottle tool, 23-24

intersecting lines, 38-40

L
Lasso tool, 34-35

layers, 3-4

creating, 62-64

deleting, 62-64

displaying outlines, 68-70

guide layers, 84-85

hiding, 68-70

locking, 67-68

mask layers, 70-71

organizing, 64-66

line styles, 28-29

M
mask animations, 86-88

mask layers

creating, 70-71

motion-tweened animation, 78-83

editing motion guide paths, 85-86

guide layers, 84-85

O
objects

aligning, 72-73

combining, 41

dividing objects using lines, 41-43

grouping, 47-48

overlapping, 36-38

transforming, 43-46

overlapping shapes, 36-38

P
Paint Bucket tool, 20-23

panels, 3-4

Pen tool, 11-15

Pencil tool, 9-11

previewing files, 94-95

Property Inspector, 3-4

publish settings, 92-94

publishing files, 94-95

R
raster graphics, 8

RGB color, 25

S
selecting objects

Arrow tool, 32-34

Lasso tool, 34-35

shape-tweened animation, 77-78

stacking order, 36-38

Stage, 3-4

stroke properties, 15-16

T
text

converting text to shapes, 57-59

text blocks

creating, 54-57

editing, 54-57

text fields, 54-57

Toolbox, 3-4

tweening, 77-78, 84-85

V
vector graphics, 8
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W
Web-safe colors, 15

work area, 3-4

INDEX
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